Ford Edge ELM connection problem

Discussion about adapters and connections - usage, problems, solutions
Post Reply
rdeage
Posts: 6
Joined: Fri Nov 02, 2018 9:18 pm
Vehicle: Ford Edge, 4 cylinder eco-boost, 2015

Ford Edge ELM connection problem

Post by rdeage » Sun Jan 06, 2019 11:53 pm

I need help. Who has a Ford Edge and uses Forscan successfully? I can't seem to find an adapter that will reliably connect. I have tried 3 different ones. Need recommendations.

egwilly
Posts: 1
Joined: Fri Sep 16, 2016 1:02 am
Vehicle: Ford F350 6.7 Diesel 2014

Re: Ford Edge ELM connection problem

Post by egwilly » Fri Jan 11, 2019 3:31 am

I bought a usb Elm from ebay already modified with the can switch for my 2013 Edge Limited. Can't remember the vendor's name. Probably many others out there. No problems since then.

BTW, the new IOS from Apple does not play well with any wireless ELM devices for monitoring with any software.....they know about it.

rdeage
Posts: 6
Joined: Fri Nov 02, 2018 9:18 pm
Vehicle: Ford Edge, 4 cylinder eco-boost, 2015

Re: Ford Edge ELM connection problem

Post by rdeage » Fri Jan 11, 2019 1:48 pm

Thank you for responding. Did you download software/drivers? If so, which ones? I have tried all the drivers I could find. The name of your adapter would be so helpful.

User avatar
Andyfocus
Posts: 385
Joined: Sun Sep 16, 2018 1:35 pm
Vehicle: ford focus 1.0 ecoboost (100ps) 2017

Re: Ford Edge ELM connection problem

Post by Andyfocus » Sun Jan 13, 2019 8:44 pm

i am the same as you just a forscan user still learning .
21/4/19 just out of hospital on heavy medican so dont expend many if any replys ....

rdeage
Posts: 6
Joined: Fri Nov 02, 2018 9:18 pm
Vehicle: Ford Edge, 4 cylinder eco-boost, 2015

Re: Ford Edge ELM connection problem

Post by rdeage » Mon Jan 14, 2019 4:04 am

Thank you, Andy. This looks like just what I will need. Now, I just have to decide on which ELM327 USB to get. Maybe it shouldn't matter if i can get the drivers right.

Post Reply