2018 Expedition connection issues

Any issues related to FORScan application
Post Reply
User avatar
Marqui
Posts: 5
Joined: Mon May 29, 2017 2:28 am
Vehicle: Expedition XLT 3.5 Ecoboost

2018 Expedition connection issues

Post by Marqui » Mon Jun 25, 2018 4:11 am

Hello All,


I just got a new 2018 Expedition XLT with as many options as I could put in it. It does not have global windows, so I got a OBDlink MX bluetooth, plugged it in and fired up Forscan.
Every time I connect to the vehicle I get warning about ABS module, lose my navigation, limited slip warnings, parking brakes and more. I clear all the warnings by hitting the left ok button.

When I try to write to to the DPM (driver door module) and PDM (passenger door module) I get service interrupted (i think that's the message).

Just sharing my experience with my 2018 Expedition and wondering if anyone else is having the same kind of issues?

As stated in other threads Ford maybe locking down modules and even using different communication protocols.

OBDlink seems to work OK with Torque and OBDWiz on my android.

Marqui

twisterrescue
Posts: 62
Joined: Sun Dec 03, 2017 3:04 am
Vehicle: 2003escapeltd
Location: eastern pennsylvania

Re: 2018 Expedition connection issues

Post by twisterrescue » Thu Jun 28, 2018 1:50 am

FORscan CAN NOT work on the 2018 navigator expedition or ecosport they require FDRS fords new system .be very careful with this at our dealer we had an early ecosport with a bcm software bug tryed to reprogram it per ford w/FDRS it BLEW UP BCM it took 10 days to get a replacement .did you get the 14 hour wrong freon recall every part of ac systwm must be replaced plant put the wrong freon in a bunch of trucks

braxx
Posts: 21
Joined: Wed Apr 13, 2016 1:52 am
Vehicle: Multiple...
Location: S.E. Michigan

Re: 2018 Expedition connection issues

Post by braxx » Thu Jun 28, 2018 3:50 pm

twisterrescue wrote:
Thu Jun 28, 2018 1:50 am
FORscan CAN NOT work on the 2018 navigator expedition or ecosport they require FDRS fords new system .be very careful with this at our dealer we had an early ecosport with a bcm software bug tryed to reprogram it per ford w/FDRS it BLEW UP BCM it took 10 days to get a replacement .did you get the 14 hour wrong freon recall every part of ac systwm must be replaced plant put the wrong freon in a bunch of trucks
Yes, Ford requires FDRS software for 2018 Exped/Nav and Ecosport but I have not confirmed that it uses a different protocol. I use the FDRS software and I have also used a highend scan tool on my 2018 Ecosport. The highend scantool was able to communicate with the Ecosport so I'm not certain that it operates on a different protocol. I suppose it could operate on a protocol that is different than what the OBDLink devices use.
I use J-2534 devices with the FDRS (Which is allowed with FDRS, no longer is a VCM2 required for the Ford OEM scan tool software.) and the aftermarket scan tool also uses a J2534 so maybe a true j2534 is needed for the 2018 Exped/Nav and Ecosport.
If I have time, I guess I could try my OBDLink, ELS27 or ELM and see if they will work with the 2018 Ecosport.

As for the A/C issue. The plant had contaminated R1234YF and it was only a certain date range of build affected.
S.E. Michigan (Metro Detroit)

User avatar
Marqui
Posts: 5
Joined: Mon May 29, 2017 2:28 am
Vehicle: Expedition XLT 3.5 Ecoboost

Re: 2018 Expedition connection issues

Post by Marqui » Sat Jun 30, 2018 12:12 pm

Hello twisterrescue & braxx,

Thank you so much for your input. I was afraid that their was an incompatability issue, but just in case I’m getting a replacement OBDLink on the hope that it was a bad reader. As far as the freon issue goes, I have not herd anything from Ford, my expedition was built in early may, do you know what the date range of the contaminated freon is?

Again thank you for the info..

Will update when I try with the knew reader. Unfortunately I am about 1500 miles away from the truck, so it will be a couple of weeks before I can try anything.

Marqui.

twisterrescue
Posts: 62
Joined: Sun Dec 03, 2017 3:04 am
Vehicle: 2003escapeltd
Location: eastern pennsylvania

Re: 2018 Expedition connection issues

Post by twisterrescue » Fri Jul 06, 2018 2:15 am

Hi sorry for the delayed reply I was on vacation .i am also screwed working on a 2018 ecosport adding FORD accessory remote start .I and a master ford tech using fords new FDRS .followed three times bcm enabled items & ipcm programming added the factory hood switch .5 hrs in this job very slow programming each item .It still does not work . called 1800 ford key tech and I went step by step check out .car will not see REQUIRED hood switch thus remote start will NOT work .tech said call ford service hotline .old IDS (FORScan) allowed me to enable hood switch .we cannot find a hood switch line for enable or disable hood switch . THE FEW guys in shop logged thru ford for ford FDRS hate this software .I am now one of them .FORD has gone backwards on this system .(FORScan) moderator sent me a reply it appears the new FDRS cars and trucks are using a new verification protocol .as for your freon call your dealer and see if any open recalls I have no idea how many units are affected .

User avatar
Marqui
Posts: 5
Joined: Mon May 29, 2017 2:28 am
Vehicle: Expedition XLT 3.5 Ecoboost

Re: 2018 Expedition connection issues

Post by Marqui » Sun Jul 08, 2018 3:15 am

Just got back home late this afternoon and my replacement OBDLink was waiting for me. Needed to run some errands but finally got a few minutes this evening. Connected the new OBDLink to the expy and repaired it to the laptop and started Forscan and low and behold no error messages in the driver information center and all modules seem the show up (I guess I must have gotten a bad one). Things are looking up.

Did not try any reprograming as it was getting dark and it’s 90 degrees here and pretty hot inside the truck without the air running(neighbors must think I’m crazy). Hopefully I’ll have some time this week to try and get global windows enabled.

Thanks again everyone for your input.

Marqui

User avatar
Marqui
Posts: 5
Joined: Mon May 29, 2017 2:28 am
Vehicle: Expedition XLT 3.5 Ecoboost

Re: 2018 Expedition connection issues

Post by Marqui » Tue Jul 10, 2018 2:13 pm

Well finally got some time last night and got around to try some reprogramming. After backing up all my modules, I started and got mixed results. I was able to turn on Bambi Mode ( fog lights with high beams) and lane change flash count but could not get Global Window enabled or temp above gauges. It seems that there are some module that can’t be written to, IPC DDM PDM. So for now I think I’m just out of luck unless the brains at FORScan can figure out how to write to thes modules.

Thanks again for your help on this.

Marqui.

Post Reply