FORScan in Ubuntu Linux 18.04

Any issues related to FORScan application
Post Reply
Posts: 2
Joined: Thu Jun 07, 2018 6:04 pm
Vehicle: F250, 6.4L Diesel, 2008

FORScan in Ubuntu Linux 18.04

Post by Bigelow1984 »

Hi all,

I became aware of FORScan a few weeks back. After reading up on it a bit, I downloaded FORScan version 2.3.15 beta for Windows and loaded it into my Ubuntu 18.04 laptop. I installed it with wine. It runs great in standard license mode. FORScan connects to my truck and reads everything fine.

But, the extended license will not work. The extended license key info is correctly loaded into the wine WIndows system.reg file. But, something isn't allowing the extended license to load into the FORScan program when it is started up. My system time/date are correct, and I verified that wine is reporting the system time correctly. I've run out of ideas as to why it isn't working. I read that there is a "wine version" of FORScan that doesn't have extended license function. I didn't download that, ( I didn't even see it as a download option ). I'm using FORScan version 2.3.15 beta for Windows.

Any recommendations as to what I can do next to get this to run with the extended license in Ubuntu 18.04 with wine?
Posts: 2
Joined: Thu Jun 07, 2018 6:04 pm
Vehicle: F250, 6.4L Diesel, 2008

Re: FORScan in Ubuntu Linux 18.04

Post by Bigelow1984 »

Well, I've been working on this all day, and I'm starting to think it's just not possible to run FORScan with the Extended License in wine/Linux. Can someone please confirm if it is actually possible. I know the Windows wine version wouldn't do it. But, I thought the newest version for WIndows had wine support for the Extended License. Am I misunderstanding?
Posts: 994
Joined: Sat Apr 18, 2015 12:41 am
Vehicle: *** Ford ***
Location: Third planet from the sun

Re: FORScan in Ubuntu Linux 18.04

Post by f-wolf »

Comparsion of FORScan applications
Posts: 2
Joined: Tue Jun 19, 2018 9:52 am
Vehicle: Transit 2.4 100 2007

Re: FORScan in Ubuntu Linux 18.04

Post by twin--turbo »

Tried tonight on my Linux "Mint" and the code goes into the registry but is not loading.

So yeah does not work.

May see if I can pass through USB in virtual box to a my windows7 "VM"

Posts: 2
Joined: Tue Jun 19, 2018 8:13 pm
Vehicle: Fusion TDCi 1.4 2006

Re: FORScan in Ubuntu Linux 18.04

Post by nick.theboatman »

Id love the opportunity to try to port to proper Linux....
Posts: 1
Joined: Thu Jul 09, 2020 4:48 pm
Vehicle: lincoln town car 8cyl 2003

Re: FORScan in Kubuntu Linux 18.04

Post by luisjr777 »

I was able to use Forscan on Kubuntu.
1. Install PlayOnLinux from software center.
2. Install Forscan for windows using PlayOnLinux.
Forscan will be in the list of programs to run inside PlayOnLinux.
2. Download USB driver CH340 from: ... _LINUX.ZIP. Install it using wine.

4. From website: ... ware-linux
Install scantool using terminal:
sudo apt-get update
sudo apt-get install scantool
sudo usermod -a -G dialout YourLinuxUserName

5. Plug the ELM327 Adapter into laptop.
6. Run PlayOnLinux
7. Run Forscan

Forscan will popup a window telling you to make sure key is in the on position.
Hit Ok. You don't need to be connected to car to setup adapter on laptop.
8. Look at the lights on the adapter, they should be blinking yellow lights.
9. Success!

Now that you have a good connection from pc to adapter, you can plug it into the car and have some fun!
Posts: 1
Joined: Mon Jun 29, 2020 10:23 pm
Vehicle: Fusion Hybrid, 2.5l, 2011

Re: FORScan in Ubuntu Linux 18.04

Post by rmbowie »

I have forscan running on Ubuntu 20.04 using wine and the extended license loads.

However, when I try something like the ABS bleed procedure or the IVD initialization the procedure stops with a "procedure interrupted" message in the log.

I was able to load the as built data to the new ABS module.

I'm planning to try with Windows to see if I get the same result. Maybe it's my wifi elm adapter...

Same result on windows and also with a USB adapter. So the problem I'm seeing is either a forscan feature or a feature of my car... not a linux problem.
Post Reply