Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Share your FORScan experience with other users
WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Wed Aug 07, 2019 5:22 pm

A few hundred kilometers ago my Mondeo mk3 2.2 tdci started getting rough idling after taking out the gear while driving.

I just checked the system through FORScan and only received lhid error b2616, which I have been driving around with for more than 50.000 km because it only seems to be referring to an lhid/ xenon level adjustment problem. I googled the error again and interestingly the first thread that popped up was a German post by a guy who was reporting the same exact error with rough idling in the same car as mine. Is there any relation between error b2616 and rough idling or is this just a big coincidence? He reported that he eventually found out that his air flow meter caused the rough idling.

Which FORScan tests or measures can I do to check what is causing this problem? According to a car repair shop the injectors are running on a regular level, but I would like to check this again myself.

The first thing I did was to reset the control device by unplugging the battery for a night. However, I did not get to drive the car yet to automatically configure the system again.
The next step will be to install a new gasoline filter, as mine is already 70000 kilometers old.

Thanks a lot for any advice! :)

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Thu Aug 15, 2019 4:58 pm

The new gasoline filter did not help, nor did the reset of the system configuration. @FORScan, what do you suggest I do next?

FORScan
Site Admin
Posts: 2616
Joined: Fri Jun 13, 2014 2:21 am

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by FORScan » Fri Aug 16, 2019 1:53 am

The problem is certainly not related to B2616, at all. Also this car should have no gasoline filter - it should have Delphi diesel fuel filter, and in our opinion it should be replaced much more often than once per 70000 km.

The sequence of actions should be standard for diesel engines: check air flow (dirty air filter, vacuum leaks), check fuel lines (vacuum leaks/air in fuel). injectors leak back test. If everything is ok, check Delphi-specific issues (metall filings in fuel filter that would mean the fuel pump produces it). In last case we would recommend to find a workshop that has great experience in Delphi fuel system, as it has a lot of specific.

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Fri Aug 16, 2019 8:03 am

Thanks a lot, Forscan. I was actually referring to the Diesel filter, not gasoline. Sorry for that.

As you suggested, I am now considering to visit a Bosch Diesel Service Center. In case there is anything I could check with Forscan still, please let me know.

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Sat Aug 17, 2019 11:14 am

The basic analysis at the Bosch Diesel Center in Germany will cost 300 EUR+, so I will try to run any test on Forscan that is possible. I will update the thread again once I know more.

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Sun Aug 18, 2019 4:03 pm

After the Diesel filter was changed by a crooked garage owner (as I found out later) and installed with tons of break cleaner that was sprayed in the air pipe to get the engine running, I am now getting error p2291. Because of this, the engine rpm went up extremely high five times for a second each. This was one terrible experience and I hope it did not damage anything.

I will check some values in forscan next.

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Tue Aug 20, 2019 1:43 pm

I just received error u1039, which is related to the vehicle speed sensor. This makes it very possible that this is what is causing the rough idling. How shoudl I proceed?

For further reference, I would very much appreciate if an experienced user could analyze my FORScan logs which are no more than 30 seconds each. Are the injector values on a regular level and the rest as well?

Log 1: I am accelerating from 0 to ~80kmh and put the gear in neutral after ~15 seconds to get the rough idling.

Thanks a ton for any advice in advance!
Attachments
1.fsl
(145.35 KiB) Downloaded 49 times
Last edited by WangDong on Tue Aug 20, 2019 1:48 pm, edited 2 times in total.

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Tue Aug 20, 2019 1:44 pm

Log 2: This is just a log from the enginge running in neutral without moving the car.
Attachments
2.fsl
(109.58 KiB) Downloaded 48 times

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Tue Aug 20, 2019 1:45 pm

Log 3: I am accelerating from 0 to ~80kmh and put the gear in neutral after ~13 seconds to get the rough idling.
Attachments
3.fsl
(145.57 KiB) Downloaded 50 times
Last edited by WangDong on Tue Aug 20, 2019 1:48 pm, edited 1 time in total.

WangDong
Posts: 27
Joined: Mon Nov 23, 2015 4:11 pm
Vehicle: Mondeo MK3, BWY, 2005, 2.2 tdci

Re: Rough idling in my Mondeo mk3 - related to error b2616? & How to fix?

Post by WangDong » Tue Aug 20, 2019 1:47 pm

Log 4: I am accelerating from 0 to ~80kmh and put the gear in neutral after ~12 seconds to get the rough idling
Attachments
4.fsl
(88.58 KiB) Downloaded 54 times

Post Reply