Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Discussion about adapters and connections - usage, problems, solutions
bufer
Posts: 10
Joined: Thu Jan 08, 2015 11:16 am
Vehicle: Focus MK3, 1.6 tdci 115 PS, 2011

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by bufer » Mon Jun 10, 2019 10:28 am

I use this fake china UCDS Pro+ . It works with Forscan with both CAN busses (Focus MK3) without any troubless, but in case of Focus MK2 I am not able to connect vehicle.
p.s.
Solved. Problem was on the can bus of the car.
Last edited by bufer on Sun Sep 22, 2019 9:37 am, edited 1 time in total.

blitz456
Posts: 2
Joined: Mon Jun 24, 2019 6:08 pm
Vehicle: Lincoln Navigator 2003

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by blitz456 » Wed Jun 26, 2019 4:52 pm

Hi would this tool be suitable for Sp177 VCMII UBP Protocol on Forscan or do I need to get SP177C?

http://www.obdexpress.co.uk/wholesale/b ... eless.html

aroniusz
Posts: 1
Joined: Fri May 04, 2018 1:30 pm
Vehicle: mondeo mk5

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by aroniusz » Sat Jul 13, 2019 7:16 am

I am using the UCDS adapter from the Forscan (original) and it worked without problems until version 2.3.15. After upgrading to newer versions, and recently 2.3.22 you can not connect to the car. Does anyone know what could have happened? I will point out that back to version 2.3.15 and UCDS software works. The protocol I connect is J2534. Please help.

Szymon_Zy
Posts: 10
Joined: Tue Apr 26, 2016 7:07 am
Vehicle: Focus MKIII 1.6 tdci

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by Szymon_Zy » Sun Aug 18, 2019 12:04 pm

If I set up J2534 connection in Forscan it still claims that elm was not found.
No ELM found. Please check connection and try again.

I'm using UCDS PRO+ and the device is listed in device manager as UCDS System (UCDS Diagnostic adapter V3 - USB\VID_0483&PID_1234&REV_0310) with driver version: 3.1.0.0
I don't see any specific to J2534 setting in configuration menu except Connection Type. Device is not listed anywhere here.

EDIT: Just installed soft from cd that came with interface and connects ok.
EDIT2: Added
- ftd2xx.dll
- libusb0.dll
- libusb0_x86.dll
- ucdsj2534.dll
to Forscan folder. It did not help.

Here are my settings. I can't chose adapter. Only bluetooth one.
Image

actilab007
Posts: 1
Joined: Mon May 11, 2015 12:35 pm
Vehicle: FOCUS CMAX 2011

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by actilab007 » Sun Aug 18, 2019 7:09 pm

io sto usando opel mdi e funziona perfettamente molto veloce e connessione stabile

bufer
Posts: 10
Joined: Thu Jan 08, 2015 11:16 am
Vehicle: Focus MK3, 1.6 tdci 115 PS, 2011

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by bufer » Sun Sep 22, 2019 9:25 am

You must copy ftd2xx.dll, ucdsj2434.dll from UCDS to Forscan folder and it will work

Post Reply