Transit MK6 Failing MAF?

Share your FORScan experience with other users
Post Reply
Purdydog
Posts: 3
Joined: Wed Jun 12, 2019 7:49 am
Vehicle: Transit 2.0 TDCI 125hp 2003

Transit MK6 Failing MAF?

Post by Purdydog » Wed Jun 19, 2019 4:11 pm

Hi All,

After some advice on the condition of my MAF on a 2003 Transit 2.0 TDCI 125bp. 120k miles

The van has a blanked off EGR Valve and K&N Filter.

Fuel economy has reduced by approx 20% recently & van seems to be over fueling with blank smoke when revving from idle and under heavy acceleration.
Attached are screen shots of forscan readings, the g/sec reading seems particularly high, but I've no idea what it should be??

I've taken the the MAF out and examined it under a microscope at work, whilst relatively clean, one of the coils looks to be missing some of its ceramic coating (I assume they are both coated??) Can post pics later if necessary.

Could the MAF be faulty? or should I ceck something else?
If so any recommendations on a replacement ? Local Ford Dealer wants £295+vat :o , I see Hella, NGK, Magneti Marelli versions advertised at £65-£90 are these worth fitting?

Thanks in advance,

P
Attachments
Maf Max at Idle.JPG
Maf Max at Idle.JPG (89.94 KiB) Viewed 161 times

denbo
Posts: 384
Joined: Mon Feb 06, 2017 3:00 pm
Vehicle: ford focus 16 zetec

Re: Transit MK6 Failing MAF?

Post by denbo » Wed Jun 19, 2019 6:38 pm

Is this screen shot with engine idling?

Purdydog
Posts: 3
Joined: Wed Jun 12, 2019 7:49 am
Vehicle: Transit 2.0 TDCI 125hp 2003

Re: Transit MK6 Failing MAF?

Post by Purdydog » Wed Jun 19, 2019 6:53 pm

Hi Denbo

The 2nd picture is at idle.
The maf seems to fluctuate between 8.5 and 12.5g/s

I’ve been advised to check turbo hoses etc for leaks also.

P

denbo
Posts: 384
Joined: Mon Feb 06, 2017 3:00 pm
Vehicle: ford focus 16 zetec

Re: Transit MK6 Failing MAF?

Post by denbo » Thu Jun 20, 2019 6:12 pm

As a estimate, i look for about 10g/sec. So that looks about right. But does it climb with rpm. And of course look for splits etc.

Purdydog
Posts: 3
Joined: Wed Jun 12, 2019 7:49 am
Vehicle: Transit 2.0 TDCI 125hp 2003

Re: Transit MK6 Failing MAF?

Post by Purdydog » Sat Jun 22, 2019 6:03 pm

Thanks Denbo

Post Reply