MAF sensor diagnose

Share your FORScan experience with other users
User avatar
fordsmax471
Posts: 160
Joined: Mon Aug 07, 2017 5:29 pm
Vehicle: Ford S-Max 2,0 TDCi 2017 PowerShift

MAF sensor diagnose

Post by fordsmax471 » Sun Feb 10, 2019 5:59 pm

Hello !

i noticed it
S-Max 2.0 TDCi 110kw
Ignition key the ON position, engine not running and MAF sensor shows 2,11 g/s

this is normal ?
Attachments
MAF sensor.PNG
Maf sensor
MAF sensor.PNG (414.66 KiB) Viewed 1528 times
ELS27 v4.0 USB

Donny
Posts: 27
Joined: Sun May 08, 2016 9:00 pm
Vehicle: Focus 1.6 Tdci 201071QP67

Re: MAF sensor diagnose

Post by Donny » Sun Feb 10, 2019 9:30 pm

That is not normal. It should read 0 when the engine is not running.

I don't know the exact figures for your engine, but at tick over I would expect it to be somewhere around 6 or 7 and be steady, and rise to high double figures under extreme load.


Hopefully someone with the same engine as you can confirm the normal expected values.

f-wolf
Posts: 480
Joined: Sat Apr 18, 2015 12:41 am
Vehicle: *** Ford ***

Re: MAF sensor diagnose

Post by f-wolf » Sun Feb 10, 2019 11:19 pm

These are the readings from a MAZDA 3 2L Petrol 2010

Ignition on Engine NOT running

Engine not running.jpg
Engine not running.jpg (54.45 KiB) Viewed 1512 times
And

Engine running ... Idling at about 750RPM
Engine Idling.jpg
Engine Idling.jpg (54.5 KiB) Viewed 1512 times

Try to clean your MAF Sensor with Sensor Cleaner first ...

User avatar
fordsmax471
Posts: 160
Joined: Mon Aug 07, 2017 5:29 pm
Vehicle: Ford S-Max 2,0 TDCi 2017 PowerShift

Re: MAF sensor diagnose

Post by fordsmax471 » Mon Feb 11, 2019 4:34 am

Thanks !

when the engine running 800rpm and maf 12g/s
i can't find the Forscan MAF sensor volt PID-s only MAF g/s and MAF hz
car mileage is 25000km
ELS27 v4.0 USB

User avatar
fordsmax471
Posts: 160
Joined: Mon Aug 07, 2017 5:29 pm
Vehicle: Ford S-Max 2,0 TDCi 2017 PowerShift

Re: MAF sensor diagnose

Post by fordsmax471 » Tue Feb 19, 2019 5:58 pm

I installed a new maf sensor today, the result is same 2.11 g/s :roll:
Attachments
new maf.PNG
new maf.PNG (395.06 KiB) Viewed 1409 times
ELS27 v4.0 USB

Pg502
Posts: 11
Joined: Sun May 12, 2019 3:18 am
Vehicle: Mustang, v6, 2011

Re: MAF sensor diagnose

Post by Pg502 » Wed May 22, 2019 1:58 am

Quick question
Can forscan via pc read the voltage from a MAF sensor ?

f-wolf
Posts: 480
Joined: Sat Apr 18, 2015 12:41 am
Vehicle: *** Ford ***

Re: MAF sensor diagnose

Post by f-wolf » Wed May 22, 2019 5:10 am

Yes !!
Engine Idling.jpg
Engine Idling.jpg (55.39 KiB) Viewed 1032 times

Pg502
Posts: 11
Joined: Sun May 12, 2019 3:18 am
Vehicle: Mustang, v6, 2011

Re: MAF sensor diagnose

Post by Pg502 » Fri May 24, 2019 1:56 am

So I have stalling and hesitation at idle for my 2011 mustang.
On forscan it shows g/s is around 5 and but the volts are at a constant “0”. What does that mean ? (Idle )

Pg502
Posts: 11
Joined: Sun May 12, 2019 3:18 am
Vehicle: Mustang, v6, 2011

Re: MAF sensor diagnose

Post by Pg502 » Fri May 24, 2019 1:59 am

4g/s***

WALK3R
Posts: 54
Joined: Sat Mar 23, 2019 7:52 am
Vehicle: Ford Trasit 2012

Re: MAF sensor diagnose

Post by WALK3R » Fri May 24, 2019 7:59 am

Pg502 wrote:
Fri May 24, 2019 1:56 am
So I have stalling and hesitation at idle for my 2011 mustang.
On forscan it shows g/s is around 5 and but the volts are at a constant “0”. What does that mean ? (Idle )
Sounds like your maf is broken, try back probing it for voltage.

Post Reply