Focus RS MK2 improper (limited) boost pressure readings

Share your FORScan experience with other users
Post Reply
Trurl
Posts: 3
Joined: Sat Jul 28, 2018 5:34 pm
Vehicle: Focus RS MK2

Focus RS MK2 improper (limited) boost pressure readings

Post by Trurl »

Hello,
there is a serious problem with MAP sensor pressure readings. Only one PID exists for this parameter, it is called "TURBO". Everything seems to be fine until the reading reaches 255 kPa, which corresponds to the boost pressure of ca. 155 kPa (255 kPa minus atmospheric pressure). All values over 255 are being cut to 255. It is not a matter of the faulty sensor - when we unplug the MAP, FORScan shows extreme values: IAT -40 °C and TURBO 255 kPa. While min. IAT is OK, the max TURBO is far too low, as it can easily reach 300 kPa and even more. Someone could think it is due to the 1-byte variable, which holds that value, but it is not. Unfortunately, the readings are NOT CONGRUENT modulo 256, they are rather FIXED to 255 for all values over 255. And because of this there is no workaround solution, so such a situation makes the whole tuning process impossible.
Are you aware of this serious bug? I can only hope it will be fixed with the next release of FORScan...
Cubrik
Posts: 3
Joined: Fri Jun 11, 2021 7:14 am
Vehicle: Ford Focus RS mark2

Re: Focus RS MK2 improper (limited) boost pressure readings

Post by Cubrik »

I know the post is very old, but I'm giving an answer anyway. I think this is because the MAP can only read 1.55 bar at most. (155 kPa)
Trurl
Posts: 3
Joined: Sat Jul 28, 2018 5:34 pm
Vehicle: Focus RS MK2

Re: Focus RS MK2 improper (limited) boost pressure readings

Post by Trurl »

1.55 bar it is well below the RS MAP sensor limit. It is rather a bug in ECU software. Allegedly there is a workaround of this problem, but no one wants to share this knowledge.
Post Reply