EGR-problem with Ford Mondeo TDCI 2.0 2007 (P1335)

Share your FORScan experience with other users
Post Reply
RonnieFredrik
Posts: 3
Joined: Wed Jul 12, 2017 5:21 pm
Vehicle: Ford Mondeo 2.0 TDCI 140hp 2007

EGR-problem with Ford Mondeo TDCI 2.0 2007 (P1335)

Post by RonnieFredrik » Thu Jul 13, 2017 1:31 pm

Hello,

Anyone who can help me analyze the following diagrams from ForeScan and give me a hint what too looking for?

The car is a Ford Mondeo TDCI 2.0 2007.

Problem:
- A broken EGR-valve was replaced with a new.
- No visual fault can be seen.
- EGR system cleaned.
- Learned values resetted
- Error code P1335, see below, keeps coming back every second time I switch on the ignition after a reset of error codes

Questions:
- Is the values below OK?
- How to know if the new EGR-valve is faulty (I have tried 2 new valves with same result)?
- How to know if the solenoid (magnetical valve that is a part of the EGR-system) is faulty?
- The electrical connection to EGR-valve is inspected and cleaned. Where too look for a potential electrical problem?


New resetted EGR-valve (Ignition on, Engine off)
Image


New resetted EGR-valve (Engine running)
Image


DTC error code:
Image

william
Posts: 110
Joined: Fri Jun 20, 2014 7:41 am

Re: EGR-problem with Ford Mondeo TDCI 2.0 2007 (P1335)

Post by william » Thu Jul 13, 2017 8:06 pm

Does egrtp v the red trace, drop to around 1 volt for a second or two when the engine is switched off then return back to 4.3 volts, if not then the fault could be with the egr throttle valve which is located inside the air intake pipe just before it connects to the intake manifold.
08 mk4 mondeo 2.0 140 bhp

RonnieFredrik
Posts: 3
Joined: Wed Jul 12, 2017 5:21 pm
Vehicle: Ford Mondeo 2.0 TDCI 140hp 2007

Re: EGR-problem with Ford Mondeo TDCI 2.0 2007 (P1335)

Post by RonnieFredrik » Thu Jul 13, 2017 8:13 pm

Thanks for the tip William.
I will take à look at it tomorrow.

Regards,
Ronnie

RonnieFredrik
Posts: 3
Joined: Wed Jul 12, 2017 5:21 pm
Vehicle: Ford Mondeo 2.0 TDCI 140hp 2007

Re: EGR-problem with Ford Mondeo TDCI 2.0 2007 (P1335)

Post by RonnieFredrik » Mon Jul 17, 2017 1:11 pm

Problem solved!

It was the EGR-valve that was faulty.
The third EGR that I bought work as it should and gives 0.97 volt on parameter EGRVP-V-VOLT instead of 0.47 volt.


//Ronnie

Post Reply