S-Max Reset Differential Pressure sensor learned values

Share your FORScan experience with other users
Post Reply
fendy
Posts: 3
Joined: Wed Jan 30, 2019 3:39 pm
Vehicle: Ford S-Max 2.0 duratorq 2008

S-Max Reset Differential Pressure sensor learned values

Post by fendy » Wed Aug 14, 2019 1:41 pm

Hi all,

After much investigation, many error codes, engine light going loco and a lot of frustration regarding DPF and the likes I came to the conclusion that on my 2008 S-Max the rubber DPF hoses leading to the Differential Pressure Sensor were toasted and ruptured. After replacing them, the pressure reading in forscan was 4.5 KPA with the engine off, so also replaced that one for a new one. The workshop manual states that after replacing the sensor, one should perform the "Differential Pressure Sensor reset learned values" procedure.

When trying to perform this service procedure in Forscan it starts, goes to 1% and then after 10 seconds states that the procedure was interrupted after which Forscan also lost the connection to the car, which requires it to be shut down and disconnected for 30 seconds.

I tried it on the latest IOS version, the latest Windows version and also some older Win versions but it still doesn't work.

Is this procedure really needed? I now get readings of 0,3 KPA when running idle, 0,8 on 1500RPM and a 1,3 at 2500 rpm, under load it gives a little more.
I've read that some other users experience similar issues.

My engine type is AZWA, which is (in) a 130HP 2008 S-Max automatic.

Any and all help would be greatly appreciated

FORScan
Site Admin
Posts: 2619
Joined: Fri Jun 13, 2014 2:21 am

Re: S-Max Reset Differential Pressure sensor learned values

Post by FORScan » Fri Aug 16, 2019 10:42 am

This is known issue on S-Max Mk1/Mondeo Mk4 with some PCMs - DPS reset service procedure "crashes" PCM (so it stops to respond and you have to turn ignition off for some time to return it back). This is not a FORScan problem but PCM firmware bug. Nevertheless, as far as we know, the procedure performs the DPS reset well.

fendy
Posts: 3
Joined: Wed Jan 30, 2019 3:39 pm
Vehicle: Ford S-Max 2.0 duratorq 2008

Re: S-Max Reset Differential Pressure sensor learned values

Post by fendy » Fri Aug 16, 2019 9:47 pm

First of all, thanks for the reply! Appreciate it!

So what you’re basicly saying is that inspite of the error message the reset did work and all should be well now?

It did go exactly as you stated with having to switch off the ignition and so on...

Again, thanks ever so much for your support!

gomonsen
Posts: 1
Joined: Sun Apr 16, 2017 12:37 pm
Vehicle: Ford S-Max Duratorq Turbo Diesel 2.0L 2009

Re: S-Max Reset Differential Pressure sensor learned values

Post by gomonsen » Fri Sep 06, 2019 7:10 pm

Hi
I had the same pronlem with a Transit 140T350
I contacted FORScan and they made a test version.
In this release I was able to do the reset without starting the engeine.
It sounded like they will apply this fix in the next version.

Post Reply