seems to hang waiting for a response

Any issues related to FORScan application
Post Reply
Milk_Man
Posts: 3
Joined: Sun Jan 14, 2018 6:17 am
Vehicle: 2018 f150 xlt 2.7l

seems to hang waiting for a response

Post by Milk_Man » Mon Jan 22, 2018 1:01 am

Hello,

I have a 2018 f150
I have been trying to use forscan so I can enable sub woofer output and a few other things.
When I connect to the truck everything seems to be ok, the problem starts when Forscan asks to enable ms switch position.
after enabling m,s Forscan detects 1 more module "IPMB" then just sits there like it is waiting for a response but not getting one.
at this point the light on the obd adapter just flashes but nothing happens.

I'm not sure if this is user error on my part or an issue with my setup.

I have tried 2 dongles one is usb (ch340) and the other is Bluetooth.
If necessary I will get a different dongle but I just want to make sure I'm not missing something first.

I have tried both windows 10 and windows 7 (same laptop with extended license)
The key is in the on position but truck is not running.


any idea what I am doing wrong?


Thanks,
Attachments
truckfor.PNG
truckfor.PNG (95.51 KiB) Viewed 3158 times

Robiaman
Posts: 2
Joined: Mon Jan 15, 2018 11:54 pm
Vehicle: F150 3.5 ecoboost 2018

Re: seems to hang waiting for a response

Post by Robiaman » Tue Jan 23, 2018 10:15 pm

Anybody solve this, I have the same issue!! Thanks

Robiaman
Posts: 2
Joined: Mon Jan 15, 2018 11:54 pm
Vehicle: F150 3.5 ecoboost 2018

Re: seems to hang waiting for a response

Post by Robiaman » Tue Jan 23, 2018 10:40 pm

This worked for me on a bbfly pro Bluetooth
In connection “Bluetooth”
Only option to select after “MS-CAN SUPPORT “auto” and MS-CAN support “Share with HS CAN”

FORScan
Site Admin
Posts: 2560
Joined: Fri Jun 13, 2014 2:21 am

Re: seems to hang waiting for a response

Post by FORScan » Wed Jan 24, 2018 12:21 am

Please send FORScan debug info to support for investigations (PM here or email ). Instruction is on Contact Us page of the main site.

Milk_Man
Posts: 3
Joined: Sun Jan 14, 2018 6:17 am
Vehicle: 2018 f150 xlt 2.7l

Re: seems to hang waiting for a response

Post by Milk_Man » Wed Jan 24, 2018 5:51 am

Robiaman wrote:This worked for me on a bbfly pro Bluetooth
In connection “Bluetooth”
Only option to select after “MS-CAN SUPPORT “auto” and MS-CAN support “Share with HS CAN”
I tried changing to "share with hs can" but no difference.
Thank you for the suggestion though.
FORScan wrote:Please send FORScan debug info to support for investigations (PM here or email ). Instruction is on Contact Us page of the main site.
logs sent thanks

Milk_Man
Posts: 3
Joined: Sun Jan 14, 2018 6:17 am
Vehicle: 2018 f150 xlt 2.7l

Re: seems to hang waiting for a response

Post by Milk_Man » Thu Jan 25, 2018 7:47 am

Thank you FORScan support for your help, it is much appreciated.

Turns out the fix was pretty simple. When FORScan would sit and wait for the IPMB module I just had to power off the ignition for 5-6 seconds then turn back to on position.
This cleared the issue with IPMB and allowed FORScan to read all modules as it should.

FORScan
Site Admin
Posts: 2560
Joined: Fri Jun 13, 2014 2:21 am

Re: seems to hang waiting for a response

Post by FORScan » Mon Apr 09, 2018 5:10 am

Sticked this thread as the problem seems to be actual for IMPB of newest (2018 MY) cars, and the only workaround that really works is the one Milk_Man found:
Milk_Man wrote: Turns out the fix was pretty simple. When FORScan would sit and wait for the IPMB module I just had to power off the ignition for 5-6 seconds then turn back to on position.
This cleared the issue with IPMB and allowed FORScan to read all modules as it should.
This has to be done only once, during the first connect after the vehicle profile is removed.

This seems to be a bug in the IPMB module firmware. We will try to implement a workaround by removing a request that causes the hanging, but so far there is no confidence it will help as other requests may fail too.

Post Reply