Focus 4" to 8" screen upgrade-help with active parking lines

Any issues related to FORScan application
Post Reply
andresmorago
Posts: 9
Joined: Thu Oct 13, 2016 11:26 pm
Vehicle: 2015 Focus SE

Focus 4" to 8" screen upgrade-help with active parking lines

Post by andresmorago » Tue Jun 20, 2017 5:40 pm

Hello

I just finished the upgrade from a non-touch Sync unit (4 inch screen) to a Myford Touch 8 inch screen on my 2015 Focus SE.

The built wire harness has worked ok as the screen boots and functions relatively ok. I did some changes using foCCCus hoping that this would help me with the configuration but no luck so far:

73 Loudspeaker quantities 2 - As i dont have a DSP on my car, i kept it this way (6 speakers)
112 In Car Entertainment 18 - Original value was 16
157 Bluetooth handsfree 9 - Original value was 8
172 Touchscreen 9 - Original value was 4
214 Integrated Control Panel 8 - Original value was 3

Im having the following issues so far. Maybe you could give me some lights about how to fix them:

APIM is looking for a non-existent DSP. I havent been able to find the correct bytes in order to program the APIM and tell it not to look for the DSP since my car doesnt have one. This is causing me the following issues:
*Speed compensated volume is always OFF. Cant turn on
*Cellphone calls dont go through the speakers
*Cant change bass/treble settings

Issues with parking aids. I have looked for the re-calibrate video camera on Forscan with no luck.I do see a "Local Interconnect Network New Module Calibration" but im unsure if this is the way.
*Parking lines (Active Guidelines linked to steering wheel) dont show when camera video is on.
*Color blocks related with parking sensors wont show on the screen when in reverse
*Video and parking audio aid are OK

Here is my current APIM AB

Accessory Protocol Interface Module
APIM   7D0-01-01  8221 9001 E2EF 
APIM   7D0-01-02  0403  4200  0225 
APIM   7D0-02-01  5552  0003  0084 
APIM   7D0-02-02  0200  0000  00DD 
APIM   7D0-02-03  0000  DC 
APIM   7D0-03-01  1F4D 4601 008E 
APIM   7D0-04-01  0103  0201  00E3 
APIM   7D0-04-02  0001  DE 


I will appreciate your help!
Last edited by andresmorago on Mon Jul 10, 2017 1:30 pm, edited 1 time in total.

andresmorago
Posts: 9
Joined: Thu Oct 13, 2016 11:26 pm
Vehicle: 2015 Focus SE

Re: Focus 4 inch to 8 inch screen upgrade - help with APIM d

Post by andresmorago » Tue Jun 20, 2017 11:57 pm

hello again

some progress....

*i disabled DSP module from the APIM. This corrected the issues related with not being able to change treble/bass - front/rear - speed compensated volume settings!
Make sure this byte is set to 2
APIM
7D0-01-01 2A21 9001 E2EF

*I was able to enable the parking aids by modifying the APIM ab data:
7D0-01-01 2A21 9001 E2EF

Now i get a small car drawing on the right top area of the screen with the 4 parking sensors.
Im still struggling on the parking active lines. After modifying the byte shown above, they momentaniosuly show for 1 or 2 seconds (they even move with the steering wheel) the very first time i boot the sync apim but they just go to the center of the screen after that and dissapear!

*last but not least important Regarding the handsfree control...no luck so far. i was hoping that this was related to the DSP but no.
calls audio do go through the speakers, neither the handsfree voice commands :?

andresmorago
Posts: 9
Joined: Thu Oct 13, 2016 11:26 pm
Vehicle: 2015 Focus SE

Re: Focus 4" to 8" screen upgrade-help with active parking l

Post by andresmorago » Mon Jul 10, 2017 1:36 pm

hello again

i made some progress recently. I have no DTC's when i run forscan diagnostics and bluetooth audio now works well.

Issue is with parking aids. Especifically the active parking lines:
-camera video goes to the screen and shows nicely
-sound feedback is OK
-car drawing with obstacle detection is OK

Parking active lines. They momentaniosuly show for 1 or 2 seconds (they even move with the steering wheel) the very first time i boot the sync apim but they just go to the center of the screen after that and dissapear!
Also, camera delay when i return to DRIVE wont work ok. video will show all the time until camera goes off and screen shows an error with the camera

Please see videoo
https://youtu.be/qbMgNHXNsT8

My car on forscan wont show any camera calibration process. Forscan admin says thats OK.

andresmorago
Posts: 9
Joined: Thu Oct 13, 2016 11:26 pm
Vehicle: 2015 Focus SE

Re: Focus 4" to 8" screen upgrade-help with active parking l

Post by andresmorago » Tue Jul 11, 2017 1:59 am

I ended up fixing this damn issue by performing a master reset from the apim menu. That simple it was :roll:
A forscan module reset couldn't fix the issue.

giovanni76
Posts: 2
Joined: Sun Nov 12, 2017 3:50 am
Vehicle: 2015 ford f150 lxt

Re: Focus 4" to 8" screen upgrade-help with active parking l

Post by giovanni76 » Mon Nov 13, 2017 1:14 pm

how did you perform a master reset ?can you please let me know ..thank you

FocusElectric
Posts: 1
Joined: Tue Nov 07, 2017 12:11 pm
Vehicle: Focus Eectric 2017

Re: Focus 4" to 8" screen upgrade-help with active parking l

Post by FocusElectric » Wed Nov 15, 2017 3:03 pm

contact me in facebook to give you all APIM codes
www.facebook.com/follow.vip

Post Reply