Fiesta ABS Service Bleed service procedure missing? SOLVED

Any issues related to FORScan application
Post Reply
MJNewton
Posts: 6
Joined: Fri Apr 21, 2017 5:32 pm
Vehicle: Fiesta, 1L Ecoboost, 2013

Fiesta ABS Service Bleed service procedure missing? SOLVED

Post by MJNewton » Sat Apr 22, 2017 7:57 am

Hi FORScan Team,

So as not to start with a question let me begin with a big thanks for this app - I've bought the Android app and have recently started using the Windows version (2.3.8 beta) for more in-depth diagnosis/control of my 2013 Fiesta (picked up as 'Ford Fiesta MY2013 EcoBoost Gasoline Turbocharged Direct Injection 1.0L 2013 ( 2013.25MY').

I have an issue and that is that I appear to be missing an 'ABS Service Bleed' service procedure function despite the release notes for v2.1.20 beta suggesting that this had been introduced:
2.1.20 beta, 2014-10-07

[...]

+ Service procedure "ABS service bleed" for vehicles with ESP:

Mondeo Mk4 2007-2011 model year
Galaxy/S-Max 2006-2010 model year
Fiesta Mk7 2008-2011 model year
Fiesta Mk7 with ABS Mk60 2013 model year
[...]
That said, my Fiesta is a Mk 7.5 but as far as I understand it is effectively a Mk 7 with a facelift and some other tweaks and so I don't imagine there would be any changes in the ABS/ESP setup? (That's quite an assumption I know)

(Incidentally, these are the service procedures I'm getting)

I did notice the following bug fix in a more recent version:
2.1.23 beta, 2014-11-20

[...]

- bug not displaying ABS Service Bleed function for some models that support it (such as Fiesta Mk7)
Could my issue be a re-occurance of this?

If you/anyone can assist I would be extremely grateful.

Regards,

Mathew
Last edited by MJNewton on Wed Jun 28, 2017 6:36 pm, edited 2 times in total.

MJNewton
Posts: 6
Joined: Fri Apr 21, 2017 5:32 pm
Vehicle: Fiesta, 1L Ecoboost, 2013

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by MJNewton » Thu May 04, 2017 10:38 pm

Can anyone offer any advice/workaround for this issue? Really keen to perform a full bleed but am stuck without this handy feature!

MJNewton
Posts: 6
Joined: Fri Apr 21, 2017 5:32 pm
Vehicle: Fiesta, 1L Ecoboost, 2013

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by MJNewton » Fri May 19, 2017 4:32 pm

I'm assuming I'm the only one to be experiencing this issue. Is there any way to raise a bug report? Naturally I would of course be more than happy to help with diagnosis/testing to aid fixing if required.

tractmec
Posts: 35
Joined: Thu May 26, 2016 11:43 pm
Vehicle: Ford F150 5.4 Triton 2005 Expedition 5.4 2003

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by tractmec » Fri May 19, 2017 5:43 pm

MJNewton wrote:I'm assuming I'm the only one to be experiencing this issue. Is there any way to raise a bug report? Naturally I would of course be more than happy to help with diagnosis/testing to aid fixing if required.
Hello M:

Attach the contents of your users\(your account file)\APPData\roaming\forscan\logfile to an emai with your problem in the subject header and a brief description in the message body and send it to contact@forscan.org, assuming you are running Win7, check in the Start menu, Program files, Forscan to be sure.

Should be a dump.bin file and a Forscan.log file in the attachment. Someone on the team will look at it and should get back to you within 2 to 5 days. At least that was my experience!

Hope this helps?

Ted

MJNewton
Posts: 6
Joined: Fri Apr 21, 2017 5:32 pm
Vehicle: Fiesta, 1L Ecoboost, 2013

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by MJNewton » Fri May 19, 2017 6:29 pm

Thanks Ted - will do just that!

srnoth
Posts: 1
Joined: Sat May 27, 2017 3:20 am
Vehicle: 2015 Ford Fiesta SFE

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by srnoth » Sat May 27, 2017 3:25 pm

Any update on this? Missing the ABS procedure on my 2015 Fiesta (1.0 Ecoboost) as well.

Edit: It seems like most of the service procedures for Mk7 Fiestas are not available for this vehicle? These are all that are available (attached).
Attachments
fiesta sfe.txt
(1.36 KiB) Downloaded 478 times
service.PNG
service.PNG (7.18 KiB) Viewed 8677 times

MJNewton
Posts: 6
Joined: Fri Apr 21, 2017 5:32 pm
Vehicle: Fiesta, 1L Ecoboost, 2013

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by MJNewton » Sat May 27, 2017 4:39 pm

I must admit I haven't had chance to email in details as Ted suggested (we're expecting a baby so other things competing for time!) so you might wish to take the lead. If you do get anywhere do post back and I will of course do the same.

This is a complete guess but I'm wondering if the service procedures shown are based not on what is detected as such, but rather what it things are available based on the vehicle detected. Perhaps the Mk 7.5 isn't (yet) on the 'known vehicles' list hence it is not even being recognised as a Mk 7 and all the service procedures it is known to support?

MJNewton
Posts: 6
Joined: Fri Apr 21, 2017 5:32 pm
Vehicle: Fiesta, 1L Ecoboost, 2013

Re: ABS Service Bleed service procedure missing? (2013 Fiest

Post by MJNewton » Wed Jun 28, 2017 6:30 pm

To follow up on this I did as Ted suggested and got in touch with the FORScan team directly and they sent a test version over which, I am pleased to report, has the ABS service function enabled for this car and works perfectly. I should perhaps caveat this by pointing out that I haven't actually used it to bleed the brakes yet but I can confirm that it successfully manipulates the ABS pump/solenoids and so I am sure it is doing what it's meant to.

I am assuming that this feature will make it in to the next public release and so in the meantime if anyone needs this test version please get in touch via PM and I'll send you the link. This is probably preferable to exposing test versions too openly in case they cause the FORScan team any issues/concerns.

Post Reply