FORScan release notes

Any issues related to FORScan application
NathanSA
Posts: 3
Joined: Fri Jan 25, 2019 9:42 am
Vehicle: 2017 Ford Ranger PX2 XLS 2.2

Re: FORScan v2.1.23 release notes

Post by NathanSA » Wed Aug 21, 2019 12:01 pm

FORScan wrote:
Thu Nov 20, 2014 1:54 pm
+ Service function "Reset pilot injection quantity learned values" for:
Galaxy 1.6/2.0 TDCi(Euro V) 2010 model year
Mondeo Mk4 1.6/2.0 TDCi(Euro V) 2007-2011 model year
Kuga 2.0 TDCi TDCi Euro V 2008-2013 model year
Focus Mk3/CMax 1.6/2.0 TDCi 2011 model year
Ford Ranger 2.2/3.2 TDCi 2011 model year
Transit 2.2/3.2 TDCi(Euro V) 2006-2014 model year
Transit Connect 1.6 TDCi (Euro V/Eco III) 2014 model year
Mazda 3 Mk2 1.6 Y6 2009 model year
Mazda 5 Mk3 1.6 Y6 2010 model year
Mazda B-series 2.2/3.2 TDCi 2011 model year
This function was added as a result of investigations on this Focus Mk3 1.6 TDCi problem:

http://forscan.org/forum/viewtopic.php?f=5&t=468

Modern diesel engines with Common Rail have so called Pilot Injection function that means injecting small volume of fuel right before the main injection event. This reduces combustion noise and improves the work. The fuel quantity of the pilot injection depends on many conditions (mode of work, wear etc), so it is a subject of self learning process. In some cases these learned data have to be reset and re-initialized (for example, if one or several injectors are replaced). Some powertrain control modules are able to calculate initial values for pilot injection quantity based on injectors' C2I codes (this is why it is so important to program new injectors in PCM). But some PCMs also require additional procedures to learn new values. For some reason, the "Reset All Adaptations" sevice function on Focus Mk3 seems to be performing incorrect initalization of these values, so this function was added to solve the problem, first of all.

I see the "Reset pilot injection quantity learned values" was implemented here for the Ranger 2.2. Is there meant to be a process followed?
I just get a wait 5sec...then a prompt to turn IGN off, then 100% indicated...
Is the engine meant to be running at the time?
Some help would be great.

Post Reply