Mazda - INJx_CMP as integer values?!?

Any issues related to FORScan application
Post Reply
tzok
Posts: 8
Joined: Fri Jun 20, 2014 5:51 pm
Vehicle: Fiat Grande Punto
Location: Bieslko-Biała, Poland
Contact:

Mazda - INJx_CMP as integer values?!?

Post by tzok » Sat Jul 26, 2014 10:57 am

INJx_CMP are reported as integer values, while they are injection volume corrections in mm^3/stroke, and are typically much less than 1, but different from 0. Typically they are reported with a precision of 0.01 mm^3/stroke.

FORScan
Site Admin
Posts: 2609
Joined: Fri Jun 13, 2014 2:21 am

Re: Mazda - INJx_CMP as integer values?!?

Post by FORScan » Mon Jul 28, 2014 10:12 am

tzok wrote:INJx_CMP are reported as integer values, while they are injection volume corrections in mm^3/stroke, and are typically much less than 1, but different from 0. Typically they are reported with a precision of 0.01 mm^3/stroke.
What is wrong exactly, only measurement unit (integer instead of mm^3/stroke) or the value is wrong as well?

Values returned by this PID may be different for different models. So investigation should be performed in every particular case. Either we need FORScan internal logs (sent to us by email), or vehicle info (content of Vehicle->configuration tab) and values returned by these PIDs (FSL or CSV).

tzok
Posts: 8
Joined: Fri Jun 20, 2014 5:51 pm
Vehicle: Fiat Grande Punto
Location: Bieslko-Biała, Poland
Contact:

Re: Mazda - INJx_CMP as integer values?!?

Post by tzok » Sat Sep 13, 2014 4:28 pm

The value should be float not integer, currently it shows 0, eventually 1 - value seems to be ok, but it lacks precision. I don't currently have any Mazda, so I can't send you logs.

FORScan
Site Admin
Posts: 2609
Joined: Fri Jun 13, 2014 2:21 am

Re: Mazda - INJx_CMP as integer values?!?

Post by FORScan » Mon Sep 22, 2014 4:32 am

This is how it looks now in 2.1.19:
INJx_CMP.png
INJx_CMP.png (8.26 KiB) Viewed 5113 times
It looks like you use outdated version of FORScan.

zboq
Posts: 3
Joined: Mon Sep 22, 2014 11:40 am
Vehicle: Mazda 6 2.0D 136KM RF5C 2004r

Re: Mazda - INJx_CMP as integer values?!?

Post by zboq » Mon Sep 22, 2014 11:47 am

This is weird, I also have the newest forscan and it also shows integer value :/.

Maybe You guys have newer version than we have ? :D
I will look into it again later after work and make a screenshot.

Edit:
This is how it looks like on my laptop.
Image

And when I look at your screen I wonder if "zeroes" means "zeroes" or maybe it's negative value ?
Mazda 6 2.0D 136KM 2004

FORScan
Site Admin
Posts: 2609
Joined: Fri Jun 13, 2014 2:21 am

Re: Mazda - INJx_CMP as integer values?!?

Post by FORScan » Thu Sep 25, 2014 9:22 am

Looks like it was fixed only for newer Mazda. Mazda 6 diesel of 2002-2004 model year have another PIDs and it was not fixed. Will be fixed in the next version. If you need a test version with this fix, please email to support.

Post Reply