2018 f550 backup camera activation

Any issues related to FORScan application
Post Reply
Kartunes
Posts: 3
Joined: Fri Dec 06, 2019 6:57 pm
Vehicle: ford f550 2018

2018 f550 backup camera activation

Post by Kartunes » Fri Dec 20, 2019 9:28 pm

I have a 2018 f550 4" screen we are adding the backup camera to. I changed the camera to present but no response from the truck. and when I change it a few things happen, the 911 assist fails to work. also says im on snyc v1 but I don't know how to change it.

larryducas
Posts: 1
Joined: Fri Dec 13, 2019 11:19 pm
Vehicle: ford f150 3.5 2015

Re: 2018 f550 backup camera activation

Post by larryducas » Thu Jan 09, 2020 8:23 pm

Same here ....

jfalat
Posts: 2
Joined: Thu Dec 06, 2018 2:03 am
Vehicle: ford f150 2011 5.0

Re: 2018 f550 backup camera activation

Post by jfalat » Tue Jan 14, 2020 7:51 pm

i have enabled a few at work on 18 and 19 f550.. go into the FCDIM and enable.. should say RVC PRESENT-FNA if i remember right..

mwheeler619
Posts: 2
Joined: Wed Jan 15, 2020 9:09 pm
Vehicle: 2017 ford f250 powerstroke

Re: 2018 f550 backup camera activation

Post by mwheeler619 » Thu Jan 16, 2020 4:57 pm

Kartunes wrote:
Fri Dec 20, 2019 9:28 pm
I have a 2018 f550 4" screen we are adding the backup camera to. I changed the camera to present but no response from the truck. and when I change it a few things happen, the 911 assist fails to work. also says im on snyc v1 but I don't know how to change it.
Did you install new oem tailgate harness with the addition of a camera or did you run new wires up to the front?

jfalat
Posts: 2
Joined: Thu Dec 06, 2018 2:03 am
Vehicle: ford f150 2011 5.0

Re: 2018 f550 backup camera activation

Post by jfalat » Sun Jan 19, 2020 1:08 am

We install the cameras on chassis cabs with mechanics bodies..the camera kit comes with a harness that plugs right into the OEM plug at the end of the frame. I have never did a kit on a truck with a tail gate.

Kartunes
Posts: 3
Joined: Fri Dec 06, 2019 6:57 pm
Vehicle: ford f550 2018

Re: 2018 f550 backup camera activation

Post by Kartunes » Wed Jan 29, 2020 10:46 pm

sorry guys I ended up using a nav-tv module
I also connected to the factory wiring in the back of the truck it looked like everything was done correctly but the truck would not recognize the camera

thank you all for the help

Post Reply