cruise control installation problem

Any issues related to FORScan application
Post Reply
danielnet13
Posts: 1
Joined: Fri Sep 13, 2019 11:24 am
Vehicle: Ford Fiesta, 1.6 TDCI, 95cv, 2010

cruise control installation problem

Post by danielnet13 » Wed Sep 18, 2019 7:47 pm

Hello everyone today and I install the cruise control at my Ford Fiesta but it doesn't work and I don't know where the problem may come from. The software is activated, I am 100% sure because the green light comes on in the instrument cluster when the car is switched on. but the button does nothing when you try to activate it.

The kit that I bought to do the installation is this on aliexpress: € 89,54 7% Off | Steering Wheel Modified Frame Speed Control Switch Cruise Control Button & Cable Kit For Ford Fiesta MK7 MK8 ST Ecosport 2013
https://s.click.aliexpress.com/e/4zHYXCuu

The LED is on the button so I think the problem may be in the yellow and red cables because the cable did not come completely, you had to put the cables in the white serial connector of the car. I have welded blue in parallel with pin 3 and red and yellow in 6 and 7 as the sellers photo says.

Dessu
Posts: 6
Joined: Thu Jun 28, 2018 11:21 pm
Vehicle: Ecosport, sigma 1.6/115hp, 2014

Re: cruise control installation problem

Post by Dessu » Sat Sep 21, 2019 6:47 pm

i have the same problem :(

User avatar
LaForge
Posts: 57
Joined: Thu Jan 19, 2017 7:42 am
Vehicle: Ford Focus 2011 - Frostwhite LaForge Edition
Location: Germany

Re: cruise control installation problem

Post by LaForge » Tue Oct 29, 2019 1:27 pm

Hi there,

what have you activated in Forscan?

You need to activate Cruise control in BCM and maybe in IPC
Then you need to activate ASL (if available)

Then reset Module ABS with forced module reset

Relearn vehicle Data in ABS section of Forscan Programming

check and delete DTC error Codes

Drive at least 30kmh to activate cruise control

I hope it helped

Best regards

Karsten
riding da White Beast :lol:

ECU Programming Service on Ford Vehicles after 2006

User avatar
LaForge
Posts: 57
Joined: Thu Jan 19, 2017 7:42 am
Vehicle: Ford Focus 2011 - Frostwhite LaForge Edition
Location: Germany

Re: cruise control installation problem

Post by LaForge » Tue Oct 29, 2019 2:11 pm

Addition:

I have read you have to change values in 4(!) Modules to get Cruise control work.
(IPC, BCM, SCCM und PCM)
You need to activate Cruise control AND Speed limiter into this 4 Modules.

Then it will work.

Also you need the 8Pin Cable to get it work.

Best regards

Karsten
riding da White Beast :lol:

ECU Programming Service on Ford Vehicles after 2006

asianbloke
Posts: 4
Joined: Fri Nov 01, 2019 3:35 am
Vehicle: Galaxy s-max zetec 1.6 tdci 2012

Re: cruise control installation problem

Post by asianbloke » Sat Nov 09, 2019 2:11 am

LaForge wrote:
Tue Oct 29, 2019 2:11 pm
Addition:

I have read you have to change values in 4(!) Modules to get Cruise control work.
(IPC, BCM, SCCM und PCM)
You need to activate Cruise control AND Speed limiter into this 4 Modules.

Then it will work.

Also you need the 8Pin Cable to get it work.

Best regards

Karsten
[8 pin cable meaning???
Is there any additional electrical connections need to be done?]

Post Reply