Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Discussion about adapters and connections - usage, problems, solutions
bufer
Posts: 11
Joined: Thu Jan 08, 2015 11:16 am
Vehicle: Focus MK3, 1.6 tdci 115 PS, 2011

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by bufer »

I use this fake china UCDS Pro+ . It works with Forscan with both CAN busses (Focus MK3) without any troubless, but in case of Focus MK2 I am not able to connect vehicle.
p.s.
Solved. Problem was on the can bus of the car.
Last edited by bufer on Sun Sep 22, 2019 9:37 am, edited 1 time in total.
blitz456
Posts: 3
Joined: Mon Jun 24, 2019 6:08 pm
Vehicle: Lincoln Navigator 2003

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by blitz456 »

Hi would this tool be suitable for Sp177 VCMII UBP Protocol on Forscan or do I need to get SP177C?

http://www.obdexpress.co.uk/wholesale/b ... eless.html
aroniusz
Posts: 1
Joined: Fri May 04, 2018 1:30 pm
Vehicle: Escape 2017

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by aroniusz »

I am using the UCDS adapter from the Forscan (original) and it worked without problems until version 2.3.15. After upgrading to newer versions, and recently 2.3.22 you can not connect to the car. Does anyone know what could have happened? I will point out that back to version 2.3.15 and UCDS software works. The protocol I connect is J2534. Please help.
Szymon_Zy
Posts: 10
Joined: Tue Apr 26, 2016 7:07 am
Vehicle: Focus MKIII 1.6 tdci

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by Szymon_Zy »

If I set up J2534 connection in Forscan it still claims that elm was not found.
No ELM found. Please check connection and try again.

I'm using UCDS PRO+ and the device is listed in device manager as UCDS System (UCDS Diagnostic adapter V3 - USB\VID_0483&PID_1234&REV_0310) with driver version: 3.1.0.0
I don't see any specific to J2534 setting in configuration menu except Connection Type. Device is not listed anywhere here.

EDIT: Just installed soft from cd that came with interface and connects ok.
EDIT2: Added
- ftd2xx.dll
- libusb0.dll
- libusb0_x86.dll
- ucdsj2534.dll
to Forscan folder. It did not help.

Here are my settings. I can't chose adapter. Only bluetooth one.
Image
actilab007
Posts: 1
Joined: Mon May 11, 2015 12:35 pm
Vehicle: FOCUS CMAX 2011

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by actilab007 »

io sto usando opel mdi e funziona perfettamente molto veloce e connessione stabile
bufer
Posts: 11
Joined: Thu Jan 08, 2015 11:16 am
Vehicle: Focus MK3, 1.6 tdci 115 PS, 2011

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by bufer »

It seems you have not instaled adapter drivers. Try to run setup file v.1.2.6.008 delivered with adapter and instal all drivers.
Last edited by bufer on Thu Apr 30, 2020 8:55 am, edited 3 times in total.
kredka74
Posts: 2
Joined: Mon Nov 06, 2017 1:06 pm
Vehicle: fiesta 1.5 2013

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by kredka74 »

Hi all!
About Forscan and MAXISYS elite and other, need install drivers J2534 thats all, then change vci in the forscan, i tested also DPA5 and working fine, so all
tools fully compatible with J2534 will work fine, only need drivers!
Regards:
kredka74
ioneng
Posts: 1
Joined: Wed Nov 06, 2019 11:38 pm
Vehicle: escape tdci 2.0 2017

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by ioneng »

I have a ucds pro+ adaptor from China. I can use it to get otc status and dashboard instruments works OK in forscan too, but when I want to go into any of the module configs, it either says request has been interrupted or forscan just hangs. I think when I tried bcm central config, it made the car restart itself and forscan froze on reading the first block.

I'm using it to mod my 2017 Escape. I made sure the car battery is charged. Also I used the software that came with the adaptor, it's ucds 1.27 or something and I was able to flash as-built file to my car.
adamk0
Posts: 1
Joined: Sun Nov 03, 2019 5:40 pm
Vehicle: F150, V8 5.0, 2013

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by adamk0 »

Here is the question to the forum experts and hopefully also FORScan developers:

What is the current status of the support for J2534 adapters?

From my experience, despite ForSACN detects the Pass-Thru devices in the current and recent versions, only the older versions (up to 2.3.15) can actually connect to the vehicle. I tested both the Toyota VCI and Volvo VIDA and they both work fine with v2.3.15, but none of them works with newer versions (like 2.3.20 or 2.3.26). FORScan connects to the adapter, but can't establish communication with the vehicle. Forum members suggested copying dll files from the adapter folder, but it didn't work for me, and I didn't see any reports of the success of this procedure with the software versions newer than 2.3.15.
Are just these two devices problematic, or it is a more general issue with Pass-Thru adapters?

Thanks,
Adam
frank1982
Posts: 1
Joined: Thu Nov 14, 2019 5:59 pm
Vehicle: ford explorer,3.5l,2014

Re: Support of J2534 (Pass-Thru) adapters in FORScan v2.2.*

Post by frank1982 »

I’m tested whit cardaq plus 2 j2534 and work fine 👌🏼👌🏼
Post Reply