2011 Ford Edge Limited Instrument Cluster failure

Car configuration discussions and experience sharing
Post Reply
rgcarnevale
Posts: 19
Joined: Thu Sep 03, 2020 8:15 pm
Vehicle: F150, Gasoline 3.5L 2011
Location: Massachusetts

2011 Ford Edge Limited Instrument Cluster failure

Post by rgcarnevale »

I attempted to update the firmware for my 2011 Ford Edge Limited Instrument Panel Cluster unfortunately the first load went through all 25 blocks with no issues but when it began to upload the Calibration file it fails as soon as it started block 2. I was hoping it was an intermittent issue with my Bluetooth connection to my OBD device so I switched to my USB unit but unfortunately have the same results. At this time I have no Instrument Cluster, no Radio, no Heat controls as they must all be tied to the IPC.

Any thoughts on how I may be able to recover?

Thanks
Ecmbuster
Posts: 1303
Joined: Sun Mar 15, 2015 4:08 am
Vehicle: Volvo Bertone and two Motorcyles
Location: On a spinning rock

Re: 2011 Ford Edge Limited Instrument Cluster failure

Post by Ecmbuster »

How did you access the firmware and what tool was used?
What was the need for the update?
Do not ask for help in PM. Use the forum to ask and answer questions!
rgcarnevale
Posts: 19
Joined: Thu Sep 03, 2020 8:15 pm
Vehicle: F150, Gasoline 3.5L 2011
Location: Massachusetts

Re: 2011 Ford Edge Limited Instrument Cluster failure

Post by rgcarnevale »

I used ForScan with OBDLink EX. My wife has been experiencing issues with temperature control, either has to crank temp setting way up to get heat mainly but lately A/C wasn't working properly. Refrigerant was fine. Since I know modules depend on other modules I checked for any that needed updates. IPC was the only one so I was hoping maybe updating that would fix issue.
Ecmbuster
Posts: 1303
Joined: Sun Mar 15, 2015 4:08 am
Vehicle: Volvo Bertone and two Motorcyles
Location: On a spinning rock

Re: 2011 Ford Edge Limited Instrument Cluster failure

Post by Ecmbuster »

What version of FORScan and where did the flash updates come from.
Do not ask for help in PM. Use the forum to ask and answer questions!
rgcarnevale
Posts: 19
Joined: Thu Sep 03, 2020 8:15 pm
Vehicle: F150, Gasoline 3.5L 2011
Location: Massachusetts

Re: 2011 Ford Edge Limited Instrument Cluster failure

Post by rgcarnevale »

Forscan 2.4.3, it was provided to me last year when I had an issue with my F150, I assume the firmware came from Motorcraft site, software downloaded it.
Ecmbuster
Posts: 1303
Joined: Sun Mar 15, 2015 4:08 am
Vehicle: Volvo Bertone and two Motorcyles
Location: On a spinning rock

Re: 2011 Ford Edge Limited Instrument Cluster failure

Post by Ecmbuster »

Post what ever scan you can assess especially the primary screen and Modules screen.
Post your VIN as well and stop playing with the Ford.
Did you change anything with a "spreadsheet"?

You mentioned "IPC was the only one so I was hoping maybe updating that would fix issue."
Are you talking about the As-Built? Is that what you did and found it at Motorcraft?
Do not ask for help in PM. Use the forum to ask and answer questions!
d150d
Posts: 15
Joined: Fri Jan 11, 2019 4:32 am
Vehicle: MKX, 3.7 305HP, 2013

Re: 2011 Ford Edge Limited Instrument Cluster failure

Post by d150d »

Firmware updates should never be attempted with wireless adapters. FORscan recommended adapter is OBDlink EX wired USB adapter. This might be your issue. I’ve updated my IPC using this cable and software version without issue. This can be a lengthy process. See post https://forscan.org/forum/viewtopic.php?f=16&t=14885
Post Reply