IPC Odometer Mileage Wrong after Programming

Car configuration discussions and experience sharing
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

I recently update Sync on my UK 2018 Focus ST and at the same time made some minor changes to the IPC - added navigation and compass. When I ran FORScan today the config information showed the following;
IPC - Instrument Panel Control Module
Part number: F1ET-10849-AKS (latest known: F1ET-10849-AKU)
Strategy : F1ET-14C026-BBG
VIN: WF05XXGCC5JYXXXXX
Odometer: 67904 miles
Total Distance: 12860.5 miles
Previous readings showed the same reading for the odometer and total distance. Any suggestions on how I might correct this and get the correct reading in the odometer?
Don Ridley
Posts: 406
Joined: Sun Apr 01, 2018 2:31 am
Vehicle: 2016 Transit Connect

Re: IPC Odometer Mileage Wrong after Programming

Post by Don Ridley »

Does the IPC show the correct odometer mileage on the cluster display? Maybe there total mileage is related to the newly activated navigation? You can reverse the changes to see what happens to the mileage readings.
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

Re: IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

Yes the correct mileage is shown on the cluster display and in configuration for PCM, SASM, ABS,PSCM, BCMii, PDM, DDM, RFA and ACM. The changes made were
720-08-01 original 0100-0896-CF changed to 0D00-0896-DB to activate compass in cluster
And
720-28-01 original FFFF-1900-67 changed to FFFF-19B0-17 to turn on Nav repeat (On looking at my notes this should perhaps have been FFBF-1900-xx although nav repeat does work)
I will try reversing the changes to see if this makes any difference.
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

Re: IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

I reversed the changes in the IPC but to no effect. After making the changes I switched everything off and left the car overnight. I then drove approximately 45 mile before again running FORScan and whilst the readings in the modules and in the IPC total distance reflected an accurate increase the Odometer reading in the IPC showed an increase of triple the mileage covered - in other words the reading went from 67904 miles to 68143 miles. I am at a loss about how to correct this and would therefore welcome any suggestions
compucar
Posts: 6
Joined: Thu Jul 11, 2019 2:18 pm
Vehicle: mazda 2, 1.4D, 2007

Re: IPC Odometer Mileage Wrong after Programming

Post by compucar »

i'm not ford expert, but in some makes of car cluster always copy the highest mileage from any installed modules at first ignition on. but in your case body control module shows proper mileage, so just try to read cluster mcu with any programmer and attach file.
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

Re: IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

Thanks for your response but I’m not sure what you mean when you say ‘read cluster mcu’ and ‘attach file to what? I have an OBDLink MX and a VCMII although I have had problems connecting the VCM to the car with FORScan.
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

Re: IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

Update - I connected FORScan to the car and changed the setting imperial to metric and the config file showed the same readings in the odometer and total mileage. (Odometer 20813 kms and total mileage 20813 kms) When I reconnected the car and reverted the setting to imperial the differences in the mileage reported in the odometer and in the total mileage were again significantly different. (Odometer 68283 miles and total mileage 12932 miles) I therefore do not know what needs to be changed in the IPC configuration to have both readings the same or if I need to change a setting in one of the other modules. Any suggestions?
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

Re: IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

Further update - i have discovered that the ipc odometer reading in the config file is in feet but being reported as in miles. My thanks to F150chief and Louage in the cyanlabs forum for their advice in trying to get to the root of this problem. All I need to do now is figure out what needs changed to get the ipc config information to reflect the odometer reading in miles and not feet.
MoJo88
Posts: 213
Joined: Mon May 18, 2020 12:18 pm
Vehicle: Mondeo Vignale 210ps 2017

Re: IPC Odometer Mileage Wrong after Programming

Post by MoJo88 »

Ff3User wrote:
Sat Sep 26, 2020 5:46 pm
Thanks for your response but I’m not sure what you mean when you say ‘read cluster mcu’ and ‘attach file to what? I have an OBDLink MX and a VCMII although I have had problems connecting the VCM to the car with FORScan.
He means disassemble the cluster and physically read the chip via soldering to a reader and posting the dump onto the forum.
Ff3User
Posts: 15
Joined: Tue Nov 22, 2016 12:20 pm
Vehicle: Focus ST 250 Turbo 2018

Re: IPC Odometer Mileage Wrong after Programming

Post by Ff3User »

Thanks for the clarification. I hope that that will not be necessary given that I have, with help, established that the reading being reported as miles is actually feet, which is equivalent to the actual mileage.
Post Reply