2019 Expedition - Mirror issues

Car configuration discussions and experience sharing
Post Reply
Jh5280
Posts: 10
Joined: Sat Dec 14, 2019 12:35 am
Vehicle: 2019 expedition platinum

2019 Expedition - Mirror issues

Post by Jh5280 » Wed Apr 01, 2020 1:29 am

Hey all,

Only posting here due to the fact that in my posts on other sites, folks seemed to be stumped. So I have a 2019 Expedition standard chassis, platinum trim, with heavy duty trailer package. First, let me say that around 90% of the things I've done with Forscan have worked flawlessly. But my issue is around the mirror settings.

I originally tried to set two major mirror functions, the lincoln style fold, and the reverse tilt. Never seemed to have an issue until I tried to perform the mirror calibration procedure for the reverse tilt, at which point I started to experience the dreading clicking mirrors, every time I would hit any of the memory buttons, regardless of the mirror settings or transmission position, i.e., in park if I hit one, the mirrors would go crazy and start clicking.

So recently, I removed the reverse tilt settings, and left only the lincoln style fold. But even with just this setting, I was still experiencing the clicking anytime I would use a memory setting. But even more troubling, is the fact that I'm also experiencing an issue where the left and right controls on the mirror switches are opposite. i.e. when trying to adjust the drivers mirror outward, I have to use the right button, which is not correct.

As soon as I remove the PDM and DDM settings, as referenced in the F150 spreadsheet, the mirror controls go back to normal and the clicking stops.

Any ideas? I'd really love to have the lincoln style fold. I've given up on the reverse tilt seeing as how it's less than useful in this product. My 2011 Jeep had the ability for both mirrors to drop when in reverse, with no customization required, this thing only does one mirror at a time and requires me to manually select which mirror I want to drop. That's pretty dumb.

Any help would be greatly appreciated, and I'm happy to provide any before or after abt files.

After talking about it on another forum, I need to ask whether it's as simple as changing a couple of the values. from the spreadsheet for the F150, given that it's only the X Axis (right to left) that seems to be off, instead of using "84" in 740-03-01 in PDM/DDM, should I be using "D4". That should inverse the X axis motor direction and the X axis sensor direction? Am I using the charts correctly?

Jh5280
Posts: 10
Joined: Sat Dec 14, 2019 12:35 am
Vehicle: 2019 expedition platinum

Re: 2019 Expedition - Mirror issues

Post by Jh5280 » Thu Apr 02, 2020 2:13 pm

Bueller?

I've now confirmed that at least one other individual with the same vehicle is experiencing the same outcome when changing the settings to "84" for PDM/DDM 740-03-01 and 741-03-01.

Would love some help here.
My original settings for these modules prior to making any changes were:
740-03-01 - DDM - BC8087
741-03-01 - PDM - BD8089

So on both of them, the only thing I changed was the fourth position to a "4". As I asked before, should it possible be "D4"?

FORScan
Site Admin
Posts: 2678
Joined: Fri Jun 13, 2014 2:21 am

Re: 2019 Expedition - Mirror issues

Post by FORScan » Tue Apr 07, 2020 7:11 am

Your case perfectly explains why we do not recommend to use As Built spreadsheets for module configuration: it is very easy to make a mistake. As already discussed by email, modifying xC4x to x84x, you enable Lincoln Auto Fold but disable 2 other options that are different for 2018 Expedition: X-Motor inverse and Y-Sensor inverse. So in your case you have to set it not to x84x, but to xCCx. But much easier is to enable the option you need in FORScan Module Configuration function:
fkdnidjbmjoiiehb.png
fkdnidjbmjoiiehb.png (113.41 KiB) Viewed 211 times

Jh5280
Posts: 10
Joined: Sat Dec 14, 2019 12:35 am
Vehicle: 2019 expedition platinum

Re: 2019 Expedition - Mirror issues

Post by Jh5280 » Tue Apr 07, 2020 1:50 pm

Yes, thank you so much Forscan team for your great support.

I'm also taking this opportunity to educate some of the other folks that I know have had similar issues. It is amazing how many folks are using the F150 As built spreadsheet, and yet to understand that there are differences also makes a lot of sense.

I will use your recommendations moving forward. Leveraging the automated module configuration rather than the ABD setup has worked for my vehicle and solved the mirror issues. Thank you again.

BTW, quick question, when using this config method, I'm assuming the Value field is queried each use correct? For example, my vehicle (platinum) shows on it's window sticker that it came with heated mirrors, but it shows disabled in the Forscan value field. Shouldn't it show enabled?

Post Reply