How to clear MyKey without admin key and programming

Car configuration discussions and experience sharing
Posts: 4
Joined: Tue Apr 20, 2021 2:47 pm
Vehicle: Ford Mondeo 2.0tdci 150hp 2018

Re: How to clear MyKey without admin key and programming

Post by Haggars »

Solved it by getting a blank key from uk locksmiths on Ebay for 42 quid and had it programmed by a local locksmith for 80 quid including blade cut. My key is now disabled 😁
Posts: 15
Joined: Tue Dec 26, 2017 12:13 pm
Vehicle: Ford, Regular Unleaded V-6, RPM 285, 2014

Re: How to clear MyKey without admin key and programming

Post by Almaleh1404 »

FORScan wrote:
Tue Dec 17, 2019 7:43 am
It is typical situation when people have MyKey enabled and have no Admin key that would allow to clear MyKey feature. Previously, our support answered that there are 2 ways to do it with FORScan:

1. Reprogram PATS - erase all known keys and program 2 new ones. This removes MyKey completely, but it is quite "heavy" way: it requires 2 working different good quality keys and PATS programming functions (in FORScan it is available not for all models).

2. Disable MyKey options in IPC and other modules if available. This removes chimes and warnings, but not MyKey itself. Some limits, like speed limit, may remain active after this procedure.

But one of our users found a workaround about how to clear MyKeys with FORScan but without any programming. It can be done in FORScan for Windows or FORScan Lite for iOS, Android. Here is the exact sequence:

1. Start the car and connect to it with FORScan.
2 Start PCM KOER test (Tests->PCM Key On Engine Running On Demand Self Test)
3. Wait until the test is completed
4. Remove keyfob from the car in case of keyless system (with engine start button). In case of standard blade key, you have to block the transponder (for example, wrap the keyfob with a foil).
5. Stop the engine (turn the ignition off)
6. Turn the igfnition On but don't run the engine.
7. Go to MyKey menu in your instrument cluster and execute Clear MyKeys option .

You now have MyKey removed.

Note: this was tested on cars with gasoline engine, not tested on diesel engines.

Please leave your feedback on this method.

Tried the second solution (Disable MyKey options in IPC) on 2015 Fusion SE (Key blade). I was able get rid of the mykey alerts if you didn’t buckle the seat belt + sound limitations + traction control option became available) BUT the speed still limited to 80 Miles ;(

Second try;
I returned MyKey options back to unable on the IPC + reset DTC then tried the PCM KOER test workaround but I wasn’t able to find MyKey menu to clear it unfortunately.
Posts: 1
Joined: Wed May 12, 2021 12:19 pm
Vehicle: Ford Explorer, V6/290, 2013

Re: How to clear MyKey without admin key and programming

Post by Asutherland »

So I followed the steps but when I cover the key in foil my car come up with a message that says ‘Starting System Fault’

How do I get around this issue to clear the MyKey
Posts: 1
Joined: Mon May 17, 2021 5:37 pm
Vehicle: 2014 F-150 Lariat

Re: How to clear MyKey without admin key and programming

Post by vorpal187 »

I went through the instructions here and elsewhere and I couldn't get my MyKey setting cleared. I have a 2014 F-150 Lariat. I bought it with one key, and promptly went about setting the MyKey up before I left the lot. Ignorance is not bliss. Anyway, I purchased an ELM 327 blutooth adapter from AMZ, and a spare transponder key that I had cut to match at a local hardware store for $1. I have remote start on my transponder key.

After getting my Forscan instance installed on my Macbook (running Win10 in Bootcamp) I followed the instructions I found here: ... %20More%20

This was tremendously helpful. I read through and followed the instructions, and it worked.

I did have one problem, however. Once the process was done, and the two programmed, working keys in hand, both would start the engine, and the MyKey setting off, the second (new) key would not remote start or unlock the doors. So, obviously the process to remove the stored keys and add new keys, doesn't effect the remote start or door lock/unlock. Has anyone else had this issue?

This is my first post, and I hope the information is helpful to someone having problems getting this to work.
Post Reply