DPF Screen on 2015 6.7 Super Duty

Car configuration discussions and experience sharing
Post Reply
rafisch
Posts: 1
Joined: Thu Oct 31, 2019 2:52 pm
Vehicle: Ford F350, 6.7 Diesel, 2015

DPF Screen on 2015 6.7 Super Duty

Post by rafisch » Fri Nov 01, 2019 5:53 pm

I have a 2015 6.7 F350 Ultimate Lariat and cannot get the DPF screen to work. I am using the following to program:

IPC 0720-01-05 **** 9*** **** DPF % Screen Enabled

What am I missing???

Bkyle05
Posts: 2
Joined: Sat Nov 24, 2018 9:11 pm
Vehicle: 2015 Ford F-350 Lariat Super Duty 6.7L Diesel

Re: DPF Screen on 2015 6.7 Super Duty

Post by Bkyle05 » Mon Nov 18, 2019 3:22 am

rafisch wrote:
Fri Nov 01, 2019 5:53 pm
I have a 2015 6.7 F350 Ultimate Lariat and cannot get the DPF screen to work. I am using the following to program:

IPC 0720-01-05 **** 9*** **** DPF % Screen Enabled

What am I missing???
Did you resolve this?

BIGJOHN621
Posts: 1
Joined: Sun Dec 17, 2017 7:00 pm
Vehicle: 2012 Ford F350 6.2l

Re: DPF Screen on 2015 6.7 Super Duty

Post by BIGJOHN621 » Sat Jan 04, 2020 7:13 pm

I have the same issue with a 2016 F350 6.7, Lariat Ultimate, build date 10/15. I found (by accident) that the code for the enable forced regen request (EITHER "F" or "7") for regen and regen/compass enables the DPF screen but NOT the forced regen. There is no effect that I noticed from the program changes you quoted above to enable DPF.

ehagerty
Posts: 1
Joined: Mon Nov 11, 2019 11:33 pm
Vehicle: 2011 Ford F250 Powerstroke Lariat 6.7

Re: DPF Screen on 2015 6.7 Super Duty

Post by ehagerty » Wed Jan 22, 2020 9:45 pm

I have tried multiple times on my 2011 lariat and it will not take a #9 to get the screen. I try and change it then to just switches it to a #1

factory as built is EA21 3A03 6FE0

if I go into the non as built and enable force regen the 6FE0 changes to 7FF0 but it does not change anything function wise but have not had it enabled longer than a week. I have tried multiple times to get it to take a #9 but it overrides it. So accepting the fact my 2011 will not show it going forward

Post Reply