Programming PATS for Australian models 1998-2006

Testing new functions
FORScan
Site Admin
Posts: 2768
Joined: Fri Jun 13, 2014 2:21 am

Re: Programming PATS for Australian models 1998-2006

Post by FORScan »

dant1612 wrote: One thing I was not able to do; In your PATS how-to you describe putting uncoded key near the transceiver and do a self check on the PATS module checking for DTCs to see whether the module and key are compatible. I was not able to do this, neither the IC or BEM supports self tests (forscan reports BEM is in charge of PATS programming). Not sure whether this is a forscan bug or module limitation
If no self-test is supported, it worth to try to just re-read DTC codes when the unprogrammed key is in the ignition lock...
paulc20

Re: Programming PATS for Australian models 1998-2006

Post by paulc20 »

I successfully erased and programmed 2 keys in my daughters 2005 BA XR6 Falcon which only had one key with it when purchased. Fantastic Result.
Thank you very much.
Paul
George V

Errers in Programming PATS for Australian models 1998-2006

Post by George V »

Hi,

Just got the extended licence, I had three working keys to my Australian ford Falcon AU2 but wanted to erase a lot key.

Proceeded with erasing all keys but could not program any keys. The reset / reprogram part of the program did not finish.

Started programming again but it stuck at "Executing service procedure..." at 0%.
I an scared to start the car with the original key due to possibility of immobilising it for ever. Please help.

Regards,
George V
User avatar
Sam1112
Posts: 26
Joined: Mon Jul 21, 2014 2:52 am
Vehicle: [AUS] Ford Fairmont Ghia [BA Mk2] [4L Straight 6]
Location: Melbourne, Victoria, Australia

Re: Errers in Programming PATS for Australian models 1998-20

Post by Sam1112 »

George V wrote:Hi,

Just got the extended licence, I had three working keys to my Australian ford Falcon AU2 but wanted to erase a lot key.

Proceeded with erasing all keys but could not program any keys. The reset / reprogram part of the program did not finish.

Started programming again but it stuck at "Executing service procedure..." at 0%.
I an scared to start the car with the original key due to possibility of immobilising it for ever. Please help.

Regards,
George V
Trying to start the car will not immoblise it for ever, the engine might start then after a few second will shut off and the Theft icon on the dash might flash, Perhaps try doing the PATS programming again with an older version of Forscan, I think version 2.2.5 http://forscan.org/download/FORScanSetup2.2.5.beta.exe should do it no trouble as thats what I last tried it on with success. But my cars is a BA not an AU.
Also take note that a Pop Up Box is not asking you for input and that it has appeared in the background, that can happen sometimes, you also have to be patient with the PATS programming as it will make you wait ten minutes before programming the keys in.

-----

Also to the user 'goldyxr' I got your message but I am not allowed to send messages on the forum for some reason, it says I have not posted enough, anyway, If you see this, great. What you need to do is open up Forscan, click on the 'About' Tab, its the one in the bottom left hand corner with a picture of a steering wheel as its icon, then click the button 'Load Licence Key' and select that file that you kept downloading, and then Forscan has the extended licence, you might have to close it and reopen the software.

I'll contact the Admins at the Forum here and see if they can help with my account messaging issue, send me another message if you see this.
Cheers, Hope that helps.
George V

Re: Programming PATS for Australian models 1998-2006

Post by George V »

Thanks for your reply Sam1112,

I ended up getting the car towed to local dealer :oops: .
Service Manager was very helpful and reprogrammed my keys for a princely sum of $55.

Valuable lesson learned....

Regards,
George V
rx20na
Posts: 1
Joined: Mon Dec 05, 2016 7:43 pm
Vehicle: Ford falcon ba xr6

Re: Programming PATS for Australian models 1998-2006

Post by rx20na »

Pm sent requesting more Info on this, i tryed it with the latest version of forscan and version 2.2.5 and have had no luck
el-dubb81
Posts: 2
Joined: Mon Feb 20, 2017 3:05 am
Vehicle: 2006 Ford Falcon XR6T

Re: Programming PATS for Australian models 1998-2006

Post by el-dubb81 »

Hi All,

Ive tried to program two new keys with similar outcome to George V - removed both keys from car's BEM and now unable to program new keys. I've also tried downloading and using earlier versions of Forscan, but to no avail.

Any ideas on what I should do now???

A breif rundown about the car.. My keys were stolen from my daily driver car (along with the car) and Ive had two new keys cut and ready to program. No codes lodged due to bad key transponder.

TIA.
KRL-94
Posts: 14
Joined: Sun May 21, 2017 10:23 am
Vehicle: 2004 ford falcon 4L inline 6 cyl

Re: Programming PATS for Australian models 1998-2006

Post by KRL-94 »

I have noticed on au falcons of any series, the key programming needs to be done twice before the system will accept the keys. will this be fixed soon??
Moose
Posts: 1
Joined: Fri Nov 03, 2017 12:25 pm
Vehicle: Falcon XR8 260kW 2003

Re: Programming PATS for Australian models 1998-2006

Post by Moose »

Hi Guys, trying to program keys for my sons BA falcon. Ignition switch broke and replace the column with one from a local wreckers. PATS starts as shown by the program erases the existing keys then allows the PATS programing to happen. I insert the key after the door locks cycle turn from off to on but nothing then happens (door locks cycling for each key I have two) Is there away I can determine if the transponder within the keys is OK or check the other components to determine where the error maybe.

Thanks in advance

Steve
adami
Posts: 2
Joined: Thu May 14, 2020 1:29 am
Vehicle: Ford Falcon 1998 EL

Re: Programming PATS for Australian models 1998-2006

Post by adami »

Hi,

I'm trying to program new keys in a 2006 BF Falcon and a 2008 SY Territory. I've got a BF Falcon ignition with 2 keys plugged into the vehicle. When I press the PATS Programming start button in Forscan it says to turn the ignition to On but dont have the engine running. I've got the ignition on with the engine off but it won't let me proceed.

They keys I've got are chipped keys and are genuine Ford but don't have a blue chip i the end as the chip is embedded into the keys. Is this part of my issue?

Thanks
Post Reply