Performance fix of china ELM327 WiFi adapter

Discussion about adapters and connections - usage, problems, solutions

Re: Performance fix of china ELM327 WiFi adapter

Postby FORScan » Wed Feb 18, 2015 3:51 am

Yes we have one (purchased recently as many of our iOS users have it). Purchased here:

http://www.aliexpress.com/snapshot/6418 ... 6201211767

What can we say about it:

Good:
1. Nice looking device
2. Relatively good quality (comparing with some other clones), works quite stable.
3. Although reported as ELM327 v2.1, it is in fact seems to be old good china ELM327 v1.5 (so it is the only china v2.1 adapter that has no problem described here viewtopic.php?f=4&t=22#p840)

Bad:
1. Still china clone (we had a hope such a nice looking device will have real v2.1 inside)
2. Quite slow (average ping 50 ms, in fact varies between 40 and 60 ms) - like on slowest Bluetooth clones. It has no serial timeout setting, so cannot be
adjusted. Such a delay is acceptable (means the whole FORScan functionality should work), but overal performance will be low.

As far as we can see, it works ok with all protocols, but we really tested only CAN. Ford SCP and Ford ISO seem to work, but we didn't test them on real vehicle.

So, we consider this device quite "average" - yes, it has enough quality to work with FORScan but quite slow. We would recommend to buy another Vgate WiFi adapter, one of our users recently posted: viewtopic.php?f=4&t=897. We have such device and use it for iOS testing, it has 20 ms of ping (after changing TCP timeout in control panel to 1 ms).

As for OBDLink MX WiFi, we noticed some problems with it as discussed here viewtopic.php?f=4&t=855, and so far are unable to understand nature of this problem and find a workaround. So for now we cannot recommend it.
FORScan
Site Admin
 
Posts: 2476
Joined: Fri Jun 13, 2014 2:21 am

Re: Performance fix of china ELM327 WiFi adapter

Postby FORScan » Wed Feb 18, 2015 10:25 am

Just tested it on real vehicle with Ford SCP and Ford ISO bus - the iCar2 adapter works fine with these protocols. It means it supports all protocols any normal ELM327 does support. Also, the adapter seems to be quite stable and power-effective, doesn't go sleep after several minutes of inactivity as other adapters may do. The only problem it is very slow (50 ms on iPhone 4).
FORScan
Site Admin
 
Posts: 2476
Joined: Fri Jun 13, 2014 2:21 am

Re: Performance fix of china ELM327 WiFi adapter

Postby King Graham » Wed Feb 18, 2015 2:29 pm

Cool, good to know. It seems that there is now also iCar3 (currently available onlt for retailers I guess):

http://www.vgate.com.cn/en/iCar%20%E2%8 ... l-243.html

The main difference may be intelligent sleep mode (no power button anymore). I hope it will be also faster althought this has not been mentioned anywhere.
King Graham
 
Posts: 4
Joined: Mon Feb 16, 2015 2:41 pm
Vehicle: BMW E91LCI 320da 2010

Re: Performance fix of china ELM327 WiFi adapter

Postby FORScan » Wed Mar 04, 2015 9:24 am

We have already 2 complaints that the new orange/blue adapters have no control panel (blank page is displayed when one tries to login to it via http), as a result the timeout delay cannot be changed. If somebody has found a way to bypass this problem, please share your experience here....
FORScan
Site Admin
 
Posts: 2476
Joined: Fri Jun 13, 2014 2:21 am

Re: Performance fix of china ELM327 WiFi adapter

Postby Yemble » Sun Apr 05, 2015 1:59 pm

FORScan wrote:We have already 2 complaints that the new orange/blue adapters have no control panel (blank page is displayed when one tries to login to it via http), as a result the timeout delay cannot be changed. If somebody has found a way to bypass this problem, please share your experience here....


Same here. Mine is the ELM327 v1.5 WiFi version.

The 192.168.0.10 address, resolves to the URL http://192.168.0.10/index.htm which is just a blank page. I've tried it with four different browsers on both Windows and Android platforms. It may be the case that there is another URL that will work, but is not the default (I have seen this before on some WiFi routers). Perhaps someone with an earlier working version of the same adapter, could share the full UNC of the Web interface when connected, as this may be a different page than http://192.168.0.10/index.htm. A long shot, I know, but worth trying.
Yemble
 
Posts: 2
Joined: Thu Apr 02, 2015 5:40 pm
Vehicle: Mondeo Mk4 1.8 TDCi

Re: Performance fix of china ELM327 WiFi adapter

Postby FORScan » Wed Apr 08, 2015 10:26 am

Found by users from russian-speaking forum:

https://hackaday.io/project/2523/logs#header

Summary: it seems developers of china ELM327 WiFi clones try to protect their adapters and block access to the WiFi chip settings. The only way to break is through UART, that requires special adapter.
FORScan
Site Admin
 
Posts: 2476
Joined: Fri Jun 13, 2014 2:21 am

Re: Performance fix of china ELM327 WiFi adapter

Postby DARBAS » Sun Jul 05, 2015 7:35 am

I just bought an ELM327 which is extremely slow shows 110 like posted above comes up a blank page when try to gain access to its control panel. It has connected to the car once but was very slow all other times it gets as far as the pcm and just hangs there. Guess it might be better as a paper weight unless some one can come up with answer to over come this issue
DARBAS
 
Posts: 15
Joined: Tue Sep 09, 2014 1:12 pm
Vehicle: 2012 Ford Falcon FG XR6 ECOLPI

Re: Performance fix of china ELM327 WiFi adapter

Postby dertrance » Sat Aug 01, 2015 4:32 pm

Hey Guys!!

I own a V-Gate thingy and I did the performance tweak... but now the thingy does not show any SSID to connect to... I did aplied the settings and, after that, the Wifi disconnected.

I'm lost, how to reset it? Any suggestions? :cry:
dertrance
 
Posts: 2
Joined: Mon Jun 15, 2015 4:25 am
Vehicle: Ford Focus Hatch Ghia || 2.0 Zetec-E || 03'

Re: Performance fix of china ELM327 WiFi adapter

Postby FORScan » Sun Aug 09, 2015 12:06 pm

What are parameters you have changed? If only timeout, it is very weird as such a change should not kill WiFi.

This is the first case like this, so we have no idea what's wrong. We believe the only way is to find type of WiFi chip and find datasheet on it that should describe reset procedure. The problem is that it will most likely reset to factory settings that are different from the ones adapter was set up for, so you may need a special connection to the chip in order to manage it.
FORScan
Site Admin
 
Posts: 2476
Joined: Fri Jun 13, 2014 2:21 am

Re: Performance fix of china ELM327 WiFi adapter

Postby dertrance » Wed Aug 12, 2015 3:46 am

Hi everyone!

@ForScan, I changed the timeout setting only, and applied. After that I remember I clicked on Advanced Settings to see others options, but it didnt open the page, that's when I realized I got disconnected. Now it does not show any SSID to connect to... so I'm locked outside :oops:
I cracked open the thingy and found out it uses Ralink RT5350F chip... I googled and found some datasheet files about it, but it's too hassle to access it, so I gave up... Maybe I buy another one...

Anyway thanks for replying! And keep the good work on ForScan apps. Loved it! :mrgreen:
dertrance
 
Posts: 2
Joined: Mon Jun 15, 2015 4:25 am
Vehicle: Ford Focus Hatch Ghia || 2.0 Zetec-E || 03'

PreviousNext

Return to Adapters & Connection

Who is online

Users browsing this forum: No registered users and 5 guests