ELM327 Problem - Please turn ignition on

Discussion about adapters and connections - usage, problems, solutions

ELM327 Problem - Please turn ignition on

Postby djtale2003 » Thu Jun 18, 2015 5:54 pm

Hi,

I bought 2 ELM327 with Bluetooth. With booth Adaptors i have the same Problem: I connect to Forscan Lite und run the Programm. A Popup appears: Please turn ignition on.
But the Ignition IS on. is there any troubleshooting available?

Greetz Dirk
djtale2003
 
Posts: 2
Joined: Mon May 25, 2015 6:56 pm
Vehicle: Mondeo MK3

Re: ELM327 Problem - Please turn ignition on

Postby fred08155 » Thu Jun 18, 2015 7:32 pm

Are the adapters paired with your device? What kind of device do you use?
Are the adapters recognized in Forscan Lite showing the MAC address in the bluetooth setup?
Did you try other software with these adapters like Torque, DashCommand and so on?`
Do you use other bluetooth devices at the same time?
fred08155
 
Posts: 214
Joined: Mon Jan 12, 2015 5:28 am
Vehicle: Ford Mondeo Turnier TDCI 96kW 2002

Re: ELM327 Problem - Please turn ignition on

Postby Automate » Thu Jun 18, 2015 7:58 pm

I had that happen to me yesterday even with my expensive OBDLink MX. I disconnected the Bluetooth scanner from the OBDII port for a moment and then plugged it back in. Problem went away.
Automate
 
Posts: 100
Joined: Sun Feb 15, 2015 8:12 pm
Location: US
Vehicle: 2010 Ford Fusion Hybrid

Re: ELM327 Problem - Please turn ignition on

Postby djtale2003 » Sat Jun 20, 2015 10:55 am

I'm using this v1.5 adapter:
$_12.JPG
$_12.JPG (21.4 KiB) Viewed 14732 times

It's paired and i have a connection to the OBD Adapter. The warning is not "No ELm found", it's "please turn on th ignition"
With Torque it's the same Problem.
The WiFi Adapter is working...
djtale2003
 
Posts: 2
Joined: Mon May 25, 2015 6:56 pm
Vehicle: Mondeo MK3

Re: ELM327 Problem - Please turn ignition on

Postby FORScan » Sun Jun 21, 2015 3:10 am

Most likely the adapter is faulty. Detailed diagnostic is possible only after analysing FORScan logs. In case of Android version, procedure of sending debug info is described at the end of first post of this thread:

viewtopic.php?f=13&t=985
FORScan
Site Admin
 
Posts: 2539
Joined: Fri Jun 13, 2014 2:21 am

Re: ELM327 Problem - Please turn ignition on

Postby pachu » Sun Jun 21, 2015 7:30 pm

I have the same problem with this bluetooth adapter.Torque is perfect but Forscan and Windows versión isn´t posible conecction.
With android versión try and is ok connection but only the start it.

Sorry for my English :D

Image
pachu
 
Posts: 5
Joined: Tue Jun 16, 2015 8:29 am
Vehicle: mazda6 MZR 2200CC 2009 125cv

Re: ELM327 Problem - Please turn ignition on

Postby FORScan » Tue Jun 23, 2015 4:07 pm

In addition to ELM327 v2.1 problem (well-described here: viewtopic.php?f=4&t=22#p840 and here: viewtopic.php?f=4&t=22&start=10#p4937), there is another problem with china adapters that makes FORScan not capable to work.

How to reproduce:

1. First time FORScan is able to connect to vehicle, but not able to identify it, or able to identify but not able to finish the connection. In some cases FORScan may connect to vehicle first time, but fail second time.
2. After it happens, FORScan and other programs are not able to connect to the adapter at all until adapter is disconnected and connected again physically (power on/off).

What happens:

1. When connected, FORScan tries to read identification information. These requests may return a lot of data. Some Bluetooth china clone adapters are not able to process this amount of data properly.

There are 3 possible scenario:
1a. Adapter returns data properly. Quite rare case.
1b. Adapter doesn't return data, but doesn't freeze. So still able to process further commands.
1c. Adapter doesn't return data and freezes. So adapter becomes unavailable.

2. In case of scenario (1c), FORScan and other software are not able to connect to the adapter until power reset.

Why it happens:

Developers of these clones use different Bluetooth-RS232 chip. Some of these chip or their firmare seem to be crude and have problems with processing requests that return lot of data. These devices are tested on OBDII software like Torque, Scanmaster and so on. The regular OBDII software don't issue requests that return lot of data.

What adapters have this problem:

This problem seem to appear only on Bluetooth adapters (clones, of course). So, this seem to be a problem of Bluetooth-RS232 chip used in these adapters or their firmware.
FORScan
Site Admin
 
Posts: 2539
Joined: Fri Jun 13, 2014 2:21 am

Re: ELM327 Problem - Please turn ignition on

Postby helloSunshine » Fri Jul 10, 2015 7:26 pm

I have exactly the same issue/behaviour with (paid version! of) Forscan Lite for Android and my ELM 327 Bluetooth adapters. SW version on these adapters is 1.4a and 1.5. It's not a cheap clone adapter, it's a VGATE OBD2.

I find it suspicious that my car is also a Mazda (CX-5 GH). Is it related to the car model/manfacturer?

There's no problem to connect Forscan Lite for Android to Wifi or USB adapters - it's working perfectly with those.

But what about BT adapters? I offer my help to debug the issue. Please let me know what info you would need.
helloSunshine
 
Posts: 6
Joined: Fri May 29, 2015 6:58 pm
Vehicle: Mazda CX-5 175-D 2013

Re: ELM327 Problem - Please turn ignition on

Postby FORScan » Sat Jul 11, 2015 10:24 am

Please provide debug info for FORScan Lite for Android as described here:

viewtopic.php?f=13&t=985

But we pretty much know what we will see here - the problem mentioned above (adapter freezes on responses that provide much data). Torque doesn't send such responses, this is why it doesn't experience this problem.

The problem can be reproduced in terminal connected to ELM327 and sending commands manually. We are ready to assists in such a "manual" tests.

This problem seems to be Bluetooth chip related (not ELM itselfs), and yes it appears much often exactly on new Mazda. We believe Mazda CAN network may have slightly other timings (than Ford).

Again, we are ready to discuss and research this issue and if there is a chance to fix it we will do it.
FORScan
Site Admin
 
Posts: 2539
Joined: Fri Jun 13, 2014 2:21 am

Re: ELM327 Problem - Please turn ignition on

Postby fred08155 » Sat Jul 11, 2015 12:31 pm

helloSunshine wrote: It's not a cheap clone adapter, it's a VGATE OBD2.

This could also be a clone. Did you buy it as "genuine ELM"? What did you pay for it?
Genuine VGATE iCar model costs several hundreds of dollars.
Last edited by fred08155 on Sun Jul 12, 2015 7:53 am, edited 1 time in total.
fred08155
 
Posts: 214
Joined: Mon Jan 12, 2015 5:28 am
Vehicle: Ford Mondeo Turnier TDCI 96kW 2002

Next

Return to Adapters & Connection

Who is online

Users browsing this forum: francoisc and 2 guests