FORScan Lite Beta for Android

Testing new functions

Re: FORScan Lite Beta for Android

Postby hybridbear » Fri May 08, 2015 1:03 am

I noticed in the iOS beta testing thread that the app costs money. When the Android beta version expires will we be forced to pay to download the non-beta version?
2013 Ford Focus Electric
2013 Ford Fusion Energi
hybridbear
 
Posts: 15
Joined: Tue May 05, 2015 9:48 pm
Vehicle: 2013 Ford Focus Electric

Re: FORScan Lite Beta for Android

Postby FORScan » Fri May 08, 2015 5:12 am

fred08155 wrote:Is there still a bug with sending debug infos?
I tried with newest beta and every time i got "failed to attach the file" when using gmail app.
When using normal email app i always get an error message "mail doesn´t respond" and email app hangs up.
Third option in menu is to make en evernote entry - but this doesn´t save any log files.


The bug was fixed and we have no other complaints like this, however this functionality might not be tested in 4.0.4 (your version of Android is 4.0.4, right), so we will check it.
FORScan
Site Admin
 
Posts: 2504
Joined: Fri Jun 13, 2014 2:21 am

Re: FORScan Lite Beta for Android

Postby fred08155 » Fri May 08, 2015 7:14 am

Other question... how long is the debug info kept?
I already had disconnected from ELM adapter when i tried to send debug info. I didn´t have any problems with Forscan for Android so far i just tried the function to export debug info.
I noticed after some tries when changing between apps for and back that after some time the live stream data disappeared. I already had the data saved to downloads folder. Maybe i hit the back button once too often, don´t know.
Yes, still working under 4.0.4 with Motorola Xoom 2 ME (MZ608).

Will the app be free for beta testers? Not sure if i tested enough to earn a copy for myself. :?

I can try sending debug info next time while still connected but i don´t know if my WLAN connection reaches that point on our terrain.
fred08155
 
Posts: 214
Joined: Mon Jan 12, 2015 5:28 am
Vehicle: Ford Mondeo Turnier TDCI 96kW 2002

Re: FORScan Lite Beta for Android

Postby FORScan » Fri May 08, 2015 11:59 am

fred08155 wrote:Is there still a bug with sending debug infos?


Yes, it seems this function doesn't work in Android 4.0. Will be fixed in the next release.

hybridbear wrote:I noticed in the iOS beta testing thread that the app costs money. When the Android beta version expires will we be forced to pay to download the non-beta version?


Yes, Android version will be paid (same cost as for iOS one), however it will be still free for our
beta-testers (any user who reported a bug, tested a function or otherwise assisted in the project
improvement).

fred08155 wrote:Other question... how long is the debug info kept?


Debug info is kept until user has clear it. Debug info logging take resources, so it is assumed the Debug
option is off by default (so enabled only when you need to collect some info for develoiper).

fred08155 wrote:I noticed after some tries when changing between apps for and back that after some time the live stream data disappeared. I already had the data saved to downloads folder. Maybe i hit the back button once too often, don?t know.


Live stream is not related to the debug info. It is kept until you started new stream or changed current PID profile (added or removed PIDs). So it is recommended to save the stream after the trip, if you need these data for further analysis.
FORScan
Site Admin
 
Posts: 2504
Joined: Fri Jun 13, 2014 2:21 am

Re: FORScan Lite Beta for Android

Postby hybridbear » Fri May 08, 2015 9:45 pm

I've noticed a couple of potential bugs. When connecting to the TCM on our Focus Electric the data will stop transmitting after a short while. I have to clear the message that appears on the screen and press the "play" button again. A short time later the data again stops transmitting. Eventually it won't connect at all to that module unless I return to the vehicle section and re-establish the connection to the car. This only happens with the TCM and not with any other module.

Also, is there any way to adjust the scale of the gauges? Some of them are way off of the numbers actually showing as output from the car. Thanks!!

Also, someone else commented about not being able to access MSCAN modules in a Fusion Energi. We also have a 2013 Fusion Energi and we cannot access any MSCAN modules with the Energi. I can access MSCAN modules in the Focus Electric. Thank you!
2013 Ford Focus Electric
2013 Ford Fusion Energi
hybridbear
 
Posts: 15
Joined: Tue May 05, 2015 9:48 pm
Vehicle: 2013 Ford Focus Electric

Re: FORScan Lite Beta for Android

Postby FORScan » Sun May 10, 2015 8:14 am

hybridbear wrote:I've noticed a couple of potential bugs. When connecting to the TCM on our Focus Electric the data will stop transmitting after a short while. I have to clear the message that appears on the screen and press the "play" button again. A short time later the data again stops transmitting. Eventually it won't connect at all to that module unless I return to the vehicle section and re-establish the connection to the car. This only happens with the TCM and not with any other module.


Can you please record this sequence of actions using Settings->Debug option and send it to us as described in the first post of this thread? Ideally, the log should contain only relevan data, so exact sequence of actions would be:

0. FORScan is disconnected
1. Enable debug option
2. Clean debug info (Vehicle(Information)->Service->Clear debug info)
3. Connect to vehicle and run live stream from TCM
4. Wait until the probelm appears
5. Stop streaming, disconnect from vehicle
6. Send us debug info (Vehicle(Information)->Service->Send debug info)

hybridbear wrote:Also, is there any way to adjust the scale of the gauges?


We planned to add zoom/pan feature later (not in the first release).

hybridbear wrote:Some of them are way off of the numbers actually showing as output from the car. Thanks!!


Can you please make screenshot of this bug and send it to us?

hybridbear wrote:Also, someone else commented about not being able to access MSCAN modules in a Fusion Energi. We also have a 2013 Fusion Energi and we cannot access any MSCAN modules with the Energi. I can access MSCAN modules in the Focus Electric. Thank you!


This bug was fixed in version 2.2.4 release on 8th of May. You can test it if you have a Windows version. Android version will be migrated to the core 2.2.4 after some time, but after iOS version.
FORScan
Site Admin
 
Posts: 2504
Joined: Fri Jun 13, 2014 2:21 am

Re: FORScan Lite Beta for Android

Postby hybridbear » Mon May 11, 2015 2:00 am

FORScan wrote:
hybridbear wrote:I've noticed a couple of potential bugs. When connecting to the TCM on our Focus Electric the data will stop transmitting after a short while. I have to clear the message that appears on the screen and press the "play" button again. A short time later the data again stops transmitting. Eventually it won't connect at all to that module unless I return to the vehicle section and re-establish the connection to the car. This only happens with the TCM and not with any other module.


Can you please record this sequence of actions using Settings->Debug option and send it to us as described in the first post of this thread? Ideally, the log should contain only relevan data, so exact sequence of actions would be:

0. FORScan is disconnected
1. Enable debug option
2. Clean debug info (Vehicle(Information)->Service->Clear debug info)
3. Connect to vehicle and run live stream from TCM
4. Wait until the probelm appears
5. Stop streaming, disconnect from vehicle
6. Send us debug info (Vehicle(Information)->Service->Send debug info)

I tried this today and it didn't work. It said "no debug info". After that I found that all my gauges that I had were lost. What caused that? What did I do wrong that I didn't have debug info? Perhaps I didn't enable debugging correctly or something...
2013 Ford Focus Electric
2013 Ford Fusion Energi
hybridbear
 
Posts: 15
Joined: Tue May 05, 2015 9:48 pm
Vehicle: 2013 Ford Focus Electric

Re: FORScan Lite Beta for Android

Postby Automate » Mon May 11, 2015 3:26 am

FORScan wrote:
mx-user wrote:4. Errors - works
Remark: dtc P2458-21 possible cause -"check the PCM for the latest calibration" what does that mean?


This means you should check if you PCM has latest firmware. This is actually 2 tasks:
- check if the calibration is latest one, if not - find latest one
- if newer ones is available, reflash PCM with new one.

Ford IDS (dealership scanner) can do both tasks. FORScan cannot do any of them yet. First one will be added in one of nearest version
Looking forward to this feature. I have some modules that I know are not at the latest version so if you need someone to beta test this let me know.
Automate
 
Posts: 100
Joined: Sun Feb 15, 2015 8:12 pm
Location: US
Vehicle: 2010 Ford Fusion Hybrid

Re: FORScan Lite Beta for Android

Postby Stesa1 » Mon May 11, 2015 10:46 am

bufer wrote:Hi, I cant connect with my bluetooth adapter (none of bluetooth 0,1,2 settings works, v0.9.5) adapter is paired succesfuly - CAN OBDII (00:18:E4:D1:23:D4). Message "ELM not found. Try connection again" occurs. Adapter works with another apps (Torque, Scanmaster) without any troubles. Its some China clone of ELM 327 v1.4.
Thanks for any ideas...


Is there anything new? Got the same problem but I have a ELM 327 V1.5
Stesa1
 
Posts: 6
Joined: Wed May 06, 2015 11:10 am
Vehicle: Mazda CX-5, 2.2 Diesel, 175PS, 2013

Re: FORScan Lite Beta for Android

Postby hybridbear » Mon May 11, 2015 12:14 pm

Automate wrote:
FORScan wrote:
mx-user wrote:4. Errors - works
Remark: dtc P2458-21 possible cause -"check the PCM for the latest calibration" what does that mean?


This means you should check if you PCM has latest firmware. This is actually 2 tasks:
- check if the calibration is latest one, if not - find latest one
- if newer ones is available, reflash PCM with new one.

Ford IDS (dealership scanner) can do both tasks. FORScan cannot do any of them yet. First one will be added in one of nearest version
Looking forward to this feature. I have some modules that I know are not at the latest version so if you need someone to beta test this let me know.

I could test this too.
2013 Ford Focus Electric
2013 Ford Fusion Energi
hybridbear
 
Posts: 15
Joined: Tue May 05, 2015 9:48 pm
Vehicle: 2013 Ford Focus Electric

PreviousNext

Return to Beta testing

Who is online

Users browsing this forum: No registered users and 1 guest