Известные проблемы с клонами ELM327

Обсуждение адаптеров и подключения к автомобилю - использование, проблемы, решения

Re: Известные проблемы с клонами ELM327

Postby FORScan » Fri Feb 12, 2016 12:53 pm

Нужно проверить ,что настройки соединения выставлены правильно: Тип: Bluetooth 0 (можно попрбовать еще Bluetooth 1), в списке Bluetooth устройств ваше устройво есть и выбрано.

Если не помогает, то второй вопрос: а после попытки подключения FORScan'ом Torque сразу коннектится, или нужно "передергивать" адаптер?
FORScan
Site Admin
 
Posts: 2540
Joined: Fri Jun 13, 2014 2:21 am

Re: Известные проблемы с клонами ELM327

Postby dizirtir » Tue Feb 16, 2016 3:03 pm

подскажите .
ELM327 при подключении вылазит на одну ошибку- U1900 и соответственно не могу прописать ключи,
я там понимаю не видит шину MS-CAN ?
Attachments
3.png
3.png (959.11 KiB) Viewed 10878 times
dizirtir
 
Posts: 3
Joined: Sun Feb 14, 2016 9:12 am
Vehicle: ford focus 2 .1.6.2007

Re: Известные проблемы с клонами ELM327

Postby FORScan » Tue Feb 16, 2016 4:36 pm

У ФФ2 больное место - разъем панели приборов. Со временем контакты окисляются и начинаются глюки панели, в т.ч. не видит шину и PCM, из-за этого может происходить блокировка PATS. Лечится пропайкой контактов разъема. Ваш это случай или нет - по имеющимся данным сказать сложно, обычно ошибок больше (например, присутствует ошибка отсутствия сигнала от датчика скорости и т.п.), и глюки панели более очевидны (хаотично загораются лампы и т.д.).

MS-CAN в PATS не участвует.
FORScan
Site Admin
 
Posts: 2540
Joined: Fri Jun 13, 2014 2:21 am

Re: Известные проблемы с клонами ELM327

Postby dizirtir » Tue Feb 16, 2016 5:33 pm

понятно, ну панель наверно врядли,вторую подключаю и та же история, наверно сам EML
хотя ELMConfig работает без проблем на обоих шинах.
спасибо.
dizirtir
 
Posts: 3
Joined: Sun Feb 14, 2016 9:12 am
Vehicle: ford focus 2 .1.6.2007

Re: Известные проблемы с клонами ELM327

Postby dizirtir » Wed Feb 17, 2016 5:38 pm

вообщем ключи прописались и инициализация панели прошла, хотя та ошибка так и была.
еще раз спасибо.
dizirtir
 
Posts: 3
Joined: Sun Feb 14, 2016 9:12 am
Vehicle: ford focus 2 .1.6.2007

Re: Известные проблемы с клонами ELM327

Postby Abeev1 » Sun Feb 21, 2016 12:30 pm

Ребята всем здравия! Заказал ELM 327 USB . На Алиэкспрессе. И не заметил, что там написано , что это версия 2.1. На фотках 1,5 и в характеристиках 1,5. Вопрос собственно в чем. Бывают ли 2.1. версии в USB исполнении?
Abeev1
 
Posts: 5
Joined: Thu Feb 18, 2016 7:22 pm
Vehicle: Ford Kuga2008 г.в.

Re: Известные проблемы с клонами ELM327

Postby FORScan » Tue Feb 23, 2016 5:16 pm

Abeev1 wrote:Ребята всем здравия! Заказал ELM 327 USB . На Алиэкспрессе. И не заметил, что там написано , что это версия 2.1. На фотках 1,5 и в характеристиках 1,5. Вопрос собственно в чем. Бывают ли 2.1. версии в USB исполнении?


Да, бывают. Но нынче надписи уже ни на что не влияют. Китайцы ставят их по одному им понятному алгоритму. Причем даже USB интерфейс не гарантирует, что будет "хороший". Вероятнее даже, что будет "плохой". Единственный способ проверки при покупке клона в магазинах типа Алиэкспресс - требовать фото платы с двух сторон с читаемыми номиналами микросхем. Если видим МК PIC18F25K80, то скорее всего хороший клон. Желательно также иметь мост USB-UART типа FTDI, Prolific или Silicon Labs.

Вот фото "плохого" клона, купленного нами на AliExpress несколько месяцев назад.

1.jpg
С виду самый обычный клон (надпись маркером сделали мы), но китайцы даже на саморезах сэкономили - корпус склеен (не скручен).
1.jpg (445.46 KiB) Viewed 10786 times


2.jpg
На фото номинал не видно, но сверху чисто китайский USB-UART чип CH340 (http://wch.cn/), вместо изученных уже вдоль и поперек чипов Prolific, FTDI и Silicon Labs. Естественно, для удешевления.
2.jpg (593.68 KiB) Viewed 10786 times


3.jpg
Мироконтроллер залит компаундом, прочитать номинал невозможно (как думаете, зачем?) Но судя по форме, это не PIC.
3.jpg (573.11 KiB) Viewed 10786 times
FORScan
Site Admin
 
Posts: 2540
Joined: Fri Jun 13, 2014 2:21 am

Re: Известные проблемы с клонами ELM327

Postby Stasilok » Wed Feb 24, 2016 1:43 pm

Имеется на руках адаптер Vgate Icar2, приобрел недавно, практически всё устраивает, скорость опроса датчиков на уровне 30 PID/с (так показывает Торк), Форскан тоже определяет скорость соединения как "Хорошо" (мин.задержка: 16-19мс)! Скорость чувствуется даже на глаз, по сравнению с моим старым дешевеньким настоящим ELM327 v1.5!
На борту адаптера версия v2.1, но как ни странно данный адаптер является качественным клоном, т.к. во-первых работает с форсканом, а во-вторых, на все проверочные запросы в терминале отвечает адекватно, без знаков вопроса! (здесь я сделал вывод, что версия тупо прописана китайцами в ручную)
Но с недавнего времени начал замечать, что при постоянной продолжительной работе в режиме опроса датчиков, например, через 5-10 минут (время варьируется) скорость опроса датчиков может упасть вплоть до 1-2-3 PID/с, что, естественно, напрягает, т.к. данные на экране считай зависают и графики рисуются кривые! Это происходит вплоть до рассоединения с ЭБУ! При повторном переподключении к ЭБУ проблема уходит опять же на неопределенное время! Аналогично раз в 5-10 минут, связь с ЭБУ может оборваться, и если Торк в этом случае делает автоматический реконнект, то в Форскане нужно в ручную опять запускать опрос датчиков! Новое подключение к ЭБУ проходит нормально!
Данная хрень происходит как в Форскане, так и в Торке!

Я правильно понимаю, что проблема скорей всего в адаптере? И можно требовать возврат средств за некачественный продукт? Адаптер стоил 10 Евро!

Может есть смысл прислать логи и там что-то можно будет увидеть на этот счет?
Mazda 6, 2.3i, 5MT, GG, 2002
Stasilok
 
Posts: 58
Joined: Thu Jun 18, 2015 9:42 pm
Vehicle: Mazda 6, 2.3i, 166 ЛС, 2002

Re: Известные проблемы с клонами ELM327

Postby FORScan » Wed Feb 24, 2016 2:01 pm

Stasilok wrote:Я правильно понимаю, что проблема скорей всего в адаптере? И можно требовать возврат средств за некачественный продукт? Адаптер стоил 10 Евро!


Да, скорее всего так и есть, и либо компоненты начинают "глючить" после нагрева, либо какие-то помехи на канале Bluetooth. Если проблема появляется стабильно через некоторое время интенсивной работы, то первый вариант. Если такой зависимости нет то второй вариант.

Stasilok wrote:Может есть смысл прислать логи и там что-то можно будет увидеть на этот счет?


Да, можно прислать логи (включить отладочную информацию в настройках), в них проблема будет видна почти наверняка.
FORScan
Site Admin
 
Posts: 2540
Joined: Fri Jun 13, 2014 2:21 am

Re: Известные проблемы с клонами ELM327

Postby Stasilok » Wed Feb 24, 2016 7:26 pm

FORScan wrote:Да, можно прислать логи (включить отладочную информацию в настройках), в них проблема будет видна почти наверняка.

Спасибо, завтра постараюсь сделать)
Mazda 6, 2.3i, 5MT, GG, 2002
Stasilok
 
Posts: 58
Joined: Thu Jun 18, 2015 9:42 pm
Vehicle: Mazda 6, 2.3i, 166 ЛС, 2002

PreviousNext

Return to Адаптеры и подключение

Who is online

Users browsing this forum: No registered users and 1 guest